Roberts Ross Ross.Roberts at
Wed May 8 08:24:01 EST 2002

I have some rsync defined as a server on one of my production systems and
use to to sync out various configuration files for services running on the
box (dhcpd, dns named.conf files & the like). Both ends are Compaq
Alpha/Tru64 5.1 systems running rsync 2.5.5.

 I'm having a fit trying to include certain files in specific subdirectories
under the main path; one such example is below:

        comment = Samba Configuration Files
        read only = yes
        path = /usr/local/samba
        uid = root
        include = lib/smb.conf private/ private/smbpasswd
        exclude = *
        hosts allow =
        hosts deny = *

My problem is that I don't get the files. If I enable verbose logging on the
server I see:

May  8 10:57:51 anaca2 rsyncd[374683]: add_exclude(lib/smb.conf,include)
May  8 10:57:51 anaca2 rsyncd[374683]:
May  8 10:57:51 anaca2 rsyncd[374683]:
May  8 10:57:51 anaca2 rsyncd[374683]: add_exclude(*,exclude)
May  8 10:57:51 anaca2 rsyncd[374683]: rsync on smb/ from (
May  8 10:57:51 anaca2 rsyncd[374683]: wrote 211 bytes  read 65 bytes  total
size 0

... and on the client I see:

# ls
# /usr/local/bin/rsync -vvv -ar anaca2::smb/ .
opening tcp connection to anaca2 port 873
Compaq Tru64 UNIX V5.1 (Rev. 732); Sat Aug 18 09:46:40 EDT 2001


receiving file list ...
received 1 names
recv_file_list done
get_local_name count=1 .
generator starting pid=119773 count=1
set modtime of . to (1017089370) Mon Mar 25 15:49:30 2002
generate_files phase=1
recv_files(1) starting
recv_files phase=1
generate_files phase=2
recv_files finished
wrote 66 bytes  read 211 bytes  554.00 bytes/sec
total size is 0  speedup is 0.00
_exit_cleanup(code=0, file=main.c, line=925): about to call exit(0)
# ls

I've tried many variations of the include-ed names.. lib/smb.conf,
/lib/smb.conf, lib/*, lib/**, *lib/smb.conf.. etc etc etc. I tried
everything on an include line with a '- *'  as the last option. Some will
create the directory names, but will still not copy the files. If I remove
the include/exclude, the entire directory contents sync as expected. What
else am I doing wrong?

Please CC me on replies; I'm not yet on the list. The Mailman page bombs out
with a bug report. :(


-Ross Roberts
 Unix/Network Administrator
 Alcatel Optical Fiber Division
 2512 Penny Rd.
 Claremont, NC 28610-8634
 (828) 459-8392 (voice)
 (828) 459-8437 (fax)
 ross.roberts at

More information about the rsync mailing list