rsync 2.5.5 compilation problems

Dave Dykstra dwd at
Wed May 1 07:32:01 EST 2002

I can't tell you about HPUX 11* or aix*, but Sunos4.1.4 compiled fine for
me, as did HPUX 10.20.  Looking at config.log might help you.  I use gcc;
I don't believe the standard cc on Sunos4 supports ANSI C.

- Dave Dykstra

On Sat, Apr 06, 2002 at 09:17:33PM +0300, Israel, David N wrote:
> Hi,
>   I compiled rsync on an HPUX 11i box, and got lots of errors about
> redefining sendfile() and sendpath().  The compilation succeeded, but the
> binary failed.  I then took a binary I had compiled on an HP11.00 box, and
> it worked fine.
>   I tried this with both gcc & the HP ansic compilers.  The same results.
>   I am attaching a full transcript of the configure & compilation session.
> The ld warning at the bottom is standard since I did not use the +DAportable
> flag.  Adding it did not solve my problem.
>   In addition, configure is failing on aix325 and SunOS 4.1.4.  Are they
> still supported?  Here is the output from AIX 3.2.5 (SunOS gives the same):
> disrael at ilx395> setenv CC /bin/cc
> disrael at ilx395> ./configure
> configure: Configuring rsync 2.5.5
> checking build system type... rs6000-ibm-aix3.2.5
> checking host system type... rs6000-ibm-aix3.2.5
> checking target system type... rs6000-ibm-aix3.2.5
> checking for gcc... /bin/cc
> checking for C compiler default output... cat: cannot open conftest.c
> configure: error: C compiler cannot create executables
>                               David Israel.
> IDC/Computing
> Intel Israel (74), Ltd.
> david.n.israel at
> Tel: 972-4-8656013
> Fax: 972-4-8656031

More information about the rsync mailing list