Anonymous rsync server on LAN

Berend Tober btober at
Fri Mar 22 09:22:04 EST 2002

I'm trying to set up a back-up file server ( that will 
rsync files from the main production file server ( The 
production file server is set up to run rsync --daemon, and I know it 
is doing so because on my backup server I can execute


and get the list of modules as follows:


Here's my /etc/rsyncd.conf file

	uid = nobody
	gid = nobody
	use chroot = yes
	read only=yes
	max connections = 2
	log file = /var/log/rsyncd.log

	hosts allow =
	hosts deny = *.*.*.*



But when, on the back-up server, I run

	rsync -avv -e ssh* /home


	rsync -avv -e ssh* /samba

nothing happens, i.e., the command just returns to the command prompt 
with no error messages or anything, and the files don't not update on

If I run

	rsync -avv -e ssh* /home


	rsync -avv -e ssh* /samba

I get prompted for the root login for, and the rsync 
appears to work fine.

I really want to use the anonymous rsync method so as to avoid having 
to type in the password manually, so that I can automate this with a 
cron script.

Please help.
Berend Tober

More information about the rsync mailing list