setgroups error in Rsync: Configuration or Missing Part?

Dave Dykstra dwd at
Tue Jun 11 09:39:15 EST 2002

On Mon, Jun 10, 2002 at 04:32:23PM -0400, Catalino Cuadrado wrote:
> I've been trying to get my two Mac OS X computers to sync using rsync
> 2.5.5. I have one set up as the host with --daemon and the other with a
> client running. I was encountering an
>  @ERROR: chroot failed error in my messages. I found that the problem lied
> in a misconfiguration of the rsyncd.conf file. I had tried to specify a
> POSIX pathway using the quoted foward-slash method. Once I got past that,
> the next error was @ERROR: setgroups failed. However, unlike chroot, I
> don't have this program on my system. I've looked on the 'net, and only
> found setgroups defined as a c function setgroups() which seemed to be
> part of the rsync raw source code. Is this an error in the rsync program
> or am I missing an external program? Where can I download this
> program/complete source code for this program?
> -Tito

Rsync is trying to use the c function which is a system call on OS X.  I've
compiled rsync on OS X but haven't tried this feature there, it is possible
it just doesn't work.  Check the server's log file; it looks like the rsync
code is printing the complete error message to the log file but only the
"failed" message to the client.  Many error messages to the client are
deliberately cryptic because rsync doesn't want to give away information to
a possible attacker.

- Dave Dykstra

More information about the rsync mailing list