Filesystem Permission problems

Leaw, Chern Jian chern.jian.leaw at
Mon Jun 10 04:44:23 EST 2002


I would like to copy my file, i.e. on 1 host machine into
another user's home directory i.e /usr/adm/ken_lee/
, on a different host machine. These 2 hosts machines, i.e host1 and host2
are on different NIS domains. 

I tried copying my file into the other user's home directory, by invoking
the rsync command on my host machine i.e host1:
# rsync -avzo /usr/oper/oper1/chern/ host2:/usr/adm/ken_lee/
(Note that chern is my user name on host1 and host2)

It produced the following error:
rcmd2: socket : The file access permissions do not allow the specified
unexpected EOF in read_timeout

Since I have root priviliges, I've even tried making user ken_lee's home
directory to have 777 access, and the same for my access, but to no avail.

I've also added user chern into host2's /etc/hosts.equiv file by adding the
following entry:
host1  chern

but it still produced the same error as above. I had also tried the editing
the .rhosts files on host1 and host2 to contain the following:
host1's .rhosts		host2's .rhosts

+ at all chern		+ at all chern	
+ at all ken_lee		host1 chern
host2 ken_lee	

but it also did not work. I did the same for the root's / .rhosts entry but
it still produced the same error.

I've tried another method of transferring my file i.e from
host1 also, but this time invoking rsync as a root user, still from host1. I
had also added the entries as follows in the /etc/hosts.equiv files of host1
and host2:

host1's /etc/hosts.equiv		host2's /etc/hosts.equiv
host2	ken_lee			host1   root
				host1   chern
and rsync did not also work!!

I had tried performing an rsh and rcp into host2 without any passwd prompts
from host2. 

I've also ask user ken_lee to instead copy from host1 in my
home directory into his, but it does not work either.

However, if a root user invokes rsync from the destination machine, i.e
host2, then gets copied successfully from host1 to host2. The
reverse, i.e invoking rsync from source machine host1 to copy
into host2 would produce the same permission error !

Could anyone help me out in this problem? Would appreciate it if someone
could provide some light. 



More information about the rsync mailing list