Rsync of filesystems with sym-links to other hosts

Leaw, Chern Jian chern.jian.leaw at
Sun Jun 9 02:40:03 EST 2002


I have a scenario where a filesystem i.e /fs13/m6.uecommon.1/wmt8/utils is
residing on a fileserver i.e. fs13. Contents of this filesystem are as

# ls -l /fs13/m6.uecommon.1/wmt8/utils 
lrwxrwxrwx ........    include-> /fs12/m6.uecommon.1/utils/include

lrwxrwxrwx ........    tool_utils-> /fs12/m6.uecommon.1/utils/tool_utils

The filesystems 	being pointed to i.e
/fs12/m6.uecommon.1/utils/include and /fs12/m6.uecommon.1/utils/tool_utils
both reside on another fileserver, i.e fs12.
They(/fs12/m6.uecommon.1/utils/tool_utils and
/fs12/m6.uecommon.1/utils/include) are NOT mounted on the /fs13 fileserver,
hence not available on the  /fs13 fileserver. 

In the /fs12/m6.uecommon.1/utils/include, for example, there are also
sym-links linking to other FILES, but these files are residing on fs12

I would like to rsync the /fs13/m6.uecommon.1/wmt8/utils filesystem on the
fs13 fileserver to another fileserver called sgfs. I've tried the following
on sgfs fileserver:
sgfs fileserver contains the /tmp directory.

rsync -avzol fs13:/fs13/m6.uecommon.1/wmt8/utils /tmp/

and also rsync -avzoL  fs13:/fs13/m6.uecommon.1/wmt8/utils /tmp/

but both ways did not get the files copied to sgfs fileserver.

Could someone point out I should rectify this problem? 

I've also tried copying filesystems of /fs12/m6.uecommon.1/ from fs12
fileserver to sgfs fileserver, then recreating the links to it from
/fs13/m6.uecommon.1/wmt8/utils in sgfs, but that seemed ineffiecient, as I
had to perform rsync 2X, one for stuffs on /fs12/m6.uecommon.1 and the other
for  /fs13/m6.uecommon.1/wmt8/utils.




More information about the rsync mailing list