option --delete still not completely working (2.5.2)

tim.conway at philips.com tim.conway at philips.com
Tue Jan 29 05:17:37 EST 2002

Like i said, I think it's a kind of a safety.  Going down entire directory 
trees that don't exist on the master can wipe out a whole lot of data, 
perhaps unintentionally.  I suspect that close to 100% of people using 
--delete pair it with --force.  Without -force, it will not replace a 
directory with something else.  It's kind of a case of "we don't want to 
by default destroy things in places that don't even exist on the source. 
It's a lot like the -f option to rm.  you do a rm -r, even as root, and it 
doesn't go where it's not explicitly permitted, but add -f (meaning I 
REALLY MEAN IT), it'll do it.  (Has this changed since i last tested it?).

Tim Conway
tim.conway at philips.com
Philips Semiconductor - Longmont TC
1880 Industrial Circle, Suite D
Longmont, CO 80501
Available via SameTime Connect within Philips, n9hmg on AIM
perl -e 'print pack(nnnnnnnnnnnn, 
".\n" '
"There are some who call me.... Tim?"

Phil Howard <phil-rsync at ipal.net>
01/28/2002 09:02 AM

        To:     Tim Conway/LMT/SC/PHILIPS at AMEC
        cc:     rsync at samba.org
        Subject:        Re: option --delete still not completely working (2.5.2)

On Mon, Jan 28, 2002 at 06:47:31AM -0800, tim.conway at philips.com wrote:

| There you go - the symlink versus the populated directory.  It's kind of 
| safety.  To bypass it, add "--force".
|      --force
|           This options tells rsync to delete directories even  if
|           they  are not empty.  This applies to both the --delete
|           option and to cases where rsync tries to copy a  normal
|           file  but  the  destination contains a directory of the
|           same name.
|           Since this option was added, deletions  were  reordered
|           to  be  done  depth-first  so  it is hardly ever needed
|           anymore except in very obscure cases.
| We have cases like this, and --force was the solution.

I'm still curious why --delete by itself didn't remove the members of
the directory at the target, since those didn't exist at the source.
It would have been helpful if the --delete documentation made a
reference to --force.

| Phil Howard - KA9WGN |   Dallas   | http://linuxhomepage.com/ |
| phil-nospam at ipal.net | Texas, USA | http://phil.ipal.org/     |

More information about the rsync mailing list