option --delete still not completely working (2.5.2)

tim.conway at philips.com tim.conway at philips.com
Tue Jan 29 01:47:31 EST 2002

There you go - the symlink versus the populated directory.  It's kind of a 
safety.  To bypass it, add "--force".
          This options tells rsync to delete directories even  if
          they  are not empty.  This applies to both the --delete
          option and to cases where rsync tries to copy a  normal
          file  but  the  destination contains a directory of the
          same name.

          Since this option was added, deletions  were  reordered
          to  be  done  depth-first  so  it is hardly ever needed
          anymore except in very obscure cases.

We have cases like this, and --force was the solution.

Tim Conway
tim.conway at philips.com
Philips Semiconductor - Longmont TC
1880 Industrial Circle, Suite D
Longmont, CO 80501
Available via SameTime Connect within Philips, n9hmg on AIM
perl -e 'print pack(nnnnnnnnnnnn, 
".\n" '
"There are some who call me.... Tim?"

Phil Howard <phil-rsync at ipal.net>
Sent by: rsync-admin at lists.samba.org
01/26/2002 07:15 PM

        To:     rsync at samba.org
        cc:     (bcc: Tim Conway/LMT/SC/PHILIPS)
        Subject:        option --delete still not completely working (2.5.2)

This problem has persisted for as long as I've used rsync.  When
the --delete option is used, not all files are deleted from the
target, even though said files are not present in the source.
The particular cases that cause this are when the target has a
directory with files, and the source is something else, at least
a symlink (this is the case I have seen).  I'm taking a guess to
say that when the checks for deletion is done, it fails to do a
recursion into the target directory to delete the files therein
because the source didn't have a directory there.

| Phil Howard - KA9WGN |   Dallas   | http://linuxhomepage.com/ |
| phil-nospam at ipal.net | Texas, USA | http://phil.ipal.org/     |

More information about the rsync mailing list