access denied error with rsync 2.5.1

Kenneth Wilder wilder at
Fri Jan 25 17:00:19 EST 2002

Hi.  I have several Linux machines running the Debian unstable distribution.
Until recently I used rsync version 2.4.6 without any problems, but after
upgrading to version 2.5.1 (using apt-get) rsync fails.  

The command that produces the error is run on oldmill ( 
rsync -av --password-file=/etc/ armada::rsync /backup/armada/home/

And the error is:
@ERROR: access denied to rsync from unknown (
rsync: connection unexpectedly closed (71 bytes read so far)
rsync error: error in rsync protocol data stream (code 12) at io.c(139)

The file on oldmill:

The rsyncd.conf file on armada:
  path = /home
  use chroot = no
  max connections = 2
  auth users = root
  hosts allow =
  secrets file = /etc/rsyncd.sec
  uid = root
  gid = root

The rsyncd.sec file on armada:

I have similar configurations on other machines and always get the same error.  When I put rsync 2.4.6 back on the remote machine everything worked fine
again.  While I don't mind using this work-around, I'd like to know if
this is a bug or if I have a misconfiguration somewhere.  I normally have
firewalls in place, but the command failed even with no firewalling.
Please let me know if any other information is needed.


Ken Wilder
Math Department, Univ. of Chicago

Kenneth Wilder, Associate Director
Program on Financial Mathematics at The University of Chicago
web:     email: wilder at
phone: (773) 702-1875

More information about the rsync mailing list