meaning of "IO Error: skipping the delete...."

Martin Pool mbp at
Wed Jan 23 18:04:53 EST 2002

On 23 Jan 2002, Nitin Agarwal <nitin.agarwal at> wrote:
> Hi,
> I am Nitin from India working with a leading Indian newspaper "The Times
> of India".
> We recently downloaded "rsync" and found it to be very useful and good
> utility.
> We tried to implement it between our main server and the DRS (Disaster
> Recovery System), located in different locations, connected by leased
> lines. The data that we want to synchronize using this utility is around
> 80 GB.

> We were successfull in synchronizing the data first time, but later on
> when we tried to use the "--delete" feature (to delete the files in DRS
> which no longer exists in the main servers) by using following command:
> [rsync -avz --delete host::module /PPI/production]
> we encounterd the following error:
> [IO Error: skipping the delete.....]
> and the rest of the process continued.
> Can you please let me know the reason & solution for the same.

Yes, this means that there was an error copying one of the files.  A
common possibility is that the process did not have permission to read
or write one of the files.

Because a problem occurred, rsync refrains from deleting any files.

This is because the error may reflect a configuration problem, and we
don't want to delete files that you may have wanted to preserve just
because you made a mistake on the command line.

If you look through the error output, or perhaps turn off -v, then you
should see messages explaining the errors.

> Thanks & Regards
> Nitin Agarwal


More information about the rsync mailing list