rsync w/ openssh hangs on linux

Eric Whiting ewhiting at
Sat Jan 5 06:56:41 EST 2002

It seems similar to Ed Santiago's problem.

This also seems similar to what I reported last month.

I had to go back to 2.4.6dev+waynenohang. That works for me.

I run solaris/linux hosts.

I'll try 2.5.1 again, but I'm pretty sure there is still a timing/IPC


Dave Dykstra wrote:
> On Fri, Jan 04, 2002 at 11:29:13AM -0800, J Robinson wrote:
> > Hello All:
> >
> > I've having repeatable problems copying files between
> > linux machines using rsync-2.5.1 and various recent
> > flavors of openssh.  The symptom when testing with a
> > single 2M file is that rsync hangs when when the file
> > is 97% transferred.
> >
> > It seems from looking at various archives that this
> > problem may be non-trivial.  I tried applying the
> > patch at
> > to
> > rsync-2.5.1, (even though it's for 2.5.0) but it
> > didn't seem to make things any better.
> >
> > I'm wondering if there are any tips to get around this
> > problem or ???
> I don't believe anybody else has reported a problem quite like that
> lately.  First, give us the output of netstat -a on both sides for the
> relevant connection so we can see if there is data in a send queue
> somewhere that's not being sent; that could indicate a TCP implementation
> problem which rsync has a great tendency to expose because of the way it
> stresses TCP.  Please try to give us as much information as you can so
> somebody else could possibly repeat it, including exact versions of all
> software involved on both sides, the speed of your network, and the exact
> command you're using.
> - Dave Dykstra

More information about the rsync mailing list