rsync error: received SIGUSR1 or SIGINT (code 20) at rsync.c(229)

Dave Dykstra dwd at
Wed Feb 13 03:40:02 EST 2002

On Tue, Feb 12, 2002 at 01:18:49PM +0100, Rönnblom Janåke /Teknous wrote:
> Trying to rsync between win2k machines.
> rsync version is 2.5.3pre (downloaded today)
> This is the message after 368100 files have been checked:
> rsync error: received SIGUSR1 or SIGINT (code 20) at rsync.c(229)
> My cmdline is :
> c:\sbin\rsync\rsync -az /cygdrive/d/Home
> xxx at --stats -v -P --timeout=84600
> I have tried with both with and without -z (-az or -a)
> On the server im using cygwinsrv with the following parameters to rsync
> --config=/etc/rsyncd.conf --daemon --no-detach

Ah, I see you posted more details for the same problem.  That message comes
when one process on the receiver side interrupts the other because it is is
about to die, and doesn't really say anything about what the real problem
might be.  I assume it's dying before 84600 seconds, right?  Have you ever
tried it without -v?  That's been known to cause problems before, although
I'm not sure if they've been fixed.  Be sure to check to see if the log
file on the server side has anything useful.  Have you ever tried pulling
the files from a server rather than pushing to it?  The rsync server mode
was never really intended for significant writing, more for reading, and it
has some quirks when used for writing (not to say that dying completely is
just a "quirk").

Again, it's possible you're running out of memory with that many files.

- Dave Dykstra

More information about the rsync mailing list