rsync windows -> unix still hanging :(

Scott Evans gse at
Sat Dec 28 06:09:01 EST 2002

I spent about 12 hours today writing a nice backup system based on 
Mike Rubel's snapshot system; but much to my dismay, when I took it 
for a test drive, I found that rsync hung on the first large directory 
I tried to back up.  Aiee!  

A few web searches later, I realized that a lot of folks have seen this 
problem.  I saw one proposed fix...

This fix is in rsync 2.5.5-2, but rsync still hangs for me.  I'm able to
sync a smaller directory but this larger one fails consistently.

My symptoms are much like the ones reported by other folks; if I run 
a command like this...
  rsync -vvv -a --delete --delete-excluded -e ssh othermachine:/c/gse/ t

...the last thing I see is
 recv_generator(vst/sync/weird/ww 2.6 presets.txt,4866)
 generate_files phase=1

There are 4867 files in the folder I'm trying to back up, for what that's
worth.  I've cruised the code briefly but I don't see anything obvious;  
then again, I barely know how the guts of rsync work as far as forking
processes and whatnot.  So I don't even know if the -vvv output is all
coming from one process.

Help!  Am I the only one still seeing this hang?

 scott evans ::

More information about the rsync mailing list