Rsync Spawns Not Dieing

Liston Bias bias at
Mon Dec 23 18:04:00 EST 2002


I am experience a problem with rsync spawned process will not die on their
own.  The problem first showed its face when I ran rsync through
/etc/inetd.conf.  I changed to running rsyncd as daemon and I still have
the problem.


1) I have rsync server setup with following parameters:

        path = /orca/data/now
        comment = file depot
        use chroot = no
        uid = orca
        gid = orca
        auth users = orca
        secrets file = /etc/rsyncd.secrets
        strict modes = yes
        read only = false
        exclude =

2) I run rsync via rc.d scripts on Solaris Box (Sun E480R).

        /usr/local/bin/rsync --daemon

3) I have 400-500 small rsyncs occur every 5 minutes from client-initiated
connections.  The rsyncs usually involve syncing one file that changes
very 5 minutes (orca data).

4) Over a 24 hours period, I usually end up with about 250 rsync processes
that did not die on their own.  I can stop/start the rsync daemon to
remove, but worry about interupting a data transfer which could effect

Has anyone encountered similar problem?  I'm running the latest Rsync
2.5.5 now.  I first noticed problem while running version 2.4.4 on server
and the upgraded to 2.5.5.  Most clients are running version 2.4.4.

- Liston

- Liston Bias                       The only lesson history has taught us
  Alumnus of Oklahoma State Univ    is that man has not yet learned anything
  Alumnus of Florida State Univ     from history.
                                                     -- Anonymous
  bias at

More information about the rsync mailing list