rsync problem behind a router

Chad Moss chad.moss at
Wed Dec 18 22:45:09 EST 2002

That's what I originally though too...I've tried it on one small
idex.htm file, and it does the same thing...

-----Original Message-----
From: rsync-admin at [mailto:rsync-admin at]
On Behalf Of Paul Haas
Sent: Wednesday, December 18, 2002 12:28 PM
To: Chad Moss
Cc: rsync at
Subject: Re: rsync problem behind a router

On Tue, 17 Dec 2002, Chad Moss wrote:

> I have used rsync on many systems, and never had a problem.  I am
> stumped on what to do with this.
> I have a box behind a LinkSys router and I can not "push" or "pull"
> to or from it from anywhere.

Does it work for very small transfers?

Does it work with --bwlimit set low enough so you never saturate your

I can not rsync large amounts of data through my LinkSys without using
--bwlimit option.  My LinkSys is doing NAT.  I think it loses track of
address translation for the ssh connection under load.  Then the ssh
session just stops.  I use --bwlimit=100, which is a third of the
available bandwidth on the far end, and it just works.

It's not a problem particular to rsync, other ssh sessions sometimes
too.  I just have more problems with rsync because I move more data that
way.  I always use "screen" for interactive sessions.

> When I try, it logs into the remote server, gets the file list and
> stops.

Could be a different problem, mine would often transfer quite a few
before stopping.

> The remote server shows a process running until I control-c out of
> it.when I do that, I get:

> rsync error: received SIGUSR1 or SIGINT (code 20) at rsync.c(229)
> rsync error: received SIGUSR1 or SIGINT (code 20) at main.c(785)

> The command I am using is:
> rsync -avz -e ssh root at
> <mailto:root at>
> /home/backup/servername/

> I have forwarded ports 22 and 873 to that machine, and I have tried
> putting it in the DMZ.
> The results do not seem to change.

> Thanks.


To unsubscribe or change options:
Before posting, read:

More information about the rsync mailing list