Rsync service on Win2k?

John Morgan Salomon john at
Tue Dec 3 13:07:00 EST 2002


do the permissions for SYSTEM have to be explicit?  I've just given full 

I've also been trying

cygrunsrv -I "RSYNC" -d "Rsync daemon" -p /usr/bin/rsync.exe -a 
"--config=/etc/rsyncd.conf --daemon --no-detach"

My /etc/rsyncd.conf file:

$ cat /etc/rsyncd.conf
use chroot = false
strict modes = false
log file = /var/log/rsyncd.log

        path = /tmp/rsync
        comment = rsync temp dir

There are no log entries in /var/log/rsyncd.log...

mount -m yields:

$ mount -m
mount -f -u -b "C:/cygwin/bin" "/usr/bin"
mount -f -u -b "C:/cygwin/lib" "/usr/lib"
mount -f -u -b "C:/cygwin" "/"
mount    -b --change-cygdrive-prefix "/cygdrive"

Thanks to everyone for the help and tips so far.



Max Bowsher wrote:

>John Morgan Salomon <john at> wrote:
>>I'm hoping someone could give me a quick tip or two on getting rsync
>>working as a Win2k service.  I'm not real proficient with Win2k, so
>> be gentle. The posts I could
>>find in the archive all seeem to have gotten past this basic problem!
>>I've installed the latest Cygwin, as well as the Cygwin rsync package.
>>cygrunsrv -I "rsyncd" -d "Rsync daemon" -p /usr/bin/rsync.exe -a
>>"--config=/etc/rsyncd.conf --daemon"
>>installs the service;  rsyncd.exe --config=/etc/rsyncd.conf --daemon
>>runs it from a bash shell,
>>but I can't seem to start it either using cygrunsrv -S "rsyncd", or
>>from the Services manager.
>>I've also tried with --no-detach and -e CYGWIN='binmode tty ntsec' on
>>the cygrunsrv command line,
>>as described at
>>Lastly, I tried getting it running via srvany.exe (from the Win2k
>>resource kit) and srvinstw, with
>>even less intelligible output.
>cygrunsrv is definitely the way to go, not srvany.
>--no-detach is *required*.
>--config=/etc/rsyncd.conf should be a no-op, as that is the default path to
>Is there any output in /var/log/rsyncd.log ?
>Post your rsyncd.conf and the output of "mount -m".

More information about the rsync mailing list