rsync: connection unexpectedly closed; reverse lookups?

Erik Enge eenge at
Fri Aug 30 10:26:00 EST 2002


My goal is to use rsync to syncronize box1 and box2.  On box2, I have a
tapedrive which I write the data I syncronize from box1 every night.

On box1, my /etc/rsyncd.conf looks like this:

  root at box1# cat /etc/rsyncd.conf 
  max connections = 1
  syslog facility = local6

      path = /tmp
      read only = yes
      comment = export of /tmp
      hosts allow = box2
      auth users = backupuser

      path = /tmp
      comment = export of /tmp
The command I run is:

  root at box2# rsync -vvv --recursive --compress box1::tmp-open /tmp/box1-tmp/

[I get the same error with ::tmp and ::tmp-open.]

This is what rsync on box2 exits with:

  opening tcp connection to box1 port 873
  rsync: connection unexpectedly closed (12 bytes read so far)
  rsync error: error in rsync protocol data stream (code 12) at io.c(150)
  _exit_cleanup(code=12, file=io.c, line=150): about to call exit(12)

In /var/log/messages on box1, I can see:

  Aug 30 15:17:42 box1 rsyncd[7666]: reverse name lookup failed 
  Aug 30 15:17:42 box1 rsyncd[7666]: forward name lookup failed 

I know that there is a DNS problem on my system so that would explain
why box1 cannot reverse lookup box2.  My question is this, then: is this
why I cannot rsync box1 and box2?  And if so, is there any way I can
tell rsync to not try to do that?

System configuration: RedHat 7.2, rsync version 2.4.6 protocol version 24
on Linux 2.4.18 x86.

Thanks for any replies,

Erik Enge.

More information about the rsync mailing list