superlifter design notes and a new proposal

Tim Potter tpot at
Mon Aug 5 17:40:03 EST 2002

On Mon, Aug 05, 2002 at 07:07:19PM +1000, Martin Pool wrote:

>   uint32 opcode
>   uint32 file_seq
>   uint32 data_length
>   byte   data[]
>   Message # (or perhaps "opcode" is a clearer name, or "command"?)  is
>   four bytes, being a 4-char ascii mnemonic.

I worked on a project where we used four character mnemonics for command
names.  Reading them in hex dumps or whatever didn't turn out to be
particularly useful.  In fact I doubt that ever actually occured.

The worst bit was those stupid four character acronyms insinuated
themselves all through the code.  It was very confusing.  It also
became more difficult to think up new names after there were more than a
couple of similar commands.  More confusion.

Write a dissector for ethereal instead.  If you're poring over hex dumps
often enough you'll end up memorising the command numbers.  (-:


More information about the rsync mailing list