Problem using -v within rsync transfer.

tim.conway at tim.conway at
Wed Oct 31 11:01:45 EST 2001

Dave:   I suspect what you need will be provided by adding --stats to your 
That'll give you something like this at the end of the transfer:
Number of files: 1
Number of files transferred: 1
Total file size: 43 bytes
Total transferred file size: 43 bytes
Literal data: 43 bytes
Matched data: 0 bytes
File list size: 30
Total bytes written: 125
Total bytes read: 36

wrote 125 bytes  read 36 bytes  322.00 bytes/sec
total size is 43  speedup is 0.27
It still doesn't solve the problem with verbosity, and the process STILL 
may hang, but less.  I've had to break my transfers down into units of 
about 60000 files each.  Ugly, but it works.  Unfortunately, it means 
--delete doesn't often help.

Tim Conway
tim.conway at
Philips Semiconductor - Longmont TC
1880 Industrial Circle, Suite D
Longmont, CO 80501
Available via SameTime Connect within Philips, n9hmg on AIM
perl -e 'print pack(nnnnnnnnnnnn, 
".\n" '
"There are some who call me.... Tim?"

"CRUISE,DAVID (A-FtCollins,ex1)" <david_cruise at>
Sent by: rsync-admin at
10/30/2001 04:40 PM

        To:     "'rsync at'" <rsync at>
        cc:     (bcc: Tim Conway/LMT/SC/PHILIPS)
        Subject:        Problem using -v within rsync transfer.


We have used rsync on a mirroring application successfully for just over a
year.  After our upgrade to 2.4.6, however, the process started failing
about 50% of the time.  The nature of our failure was that the rsync
processes on the remote system would die with no error message, leaving 
local system processes hung.  I have netstat and trace output for 
if needed, but I see that others have sent this information in.

Other details of the transfer include: our platforms are HPUX 10.20 (each
with 1.5GB Ram), the total data size is around 20GB, a typical transfer is
around 300MB (around 40,000 files).

After reading several other postings, we tried removing the -v from our
rsync command and our success rate improved dramatically (12 successes in 
row now).

What other platforms have this issue with -v?  Is there a known fix, or is 
fix in progress?

I ask because part of our process has always included a transfer size and
performance report.  Without some verbosity, -v, this information is not
obviously available.

Thank you for any workarounds or updates,

Dave Cruise          |4380 Ziegler Rd, MS 72
Agilent Technologies |Ft. Collins, CO 80525
IT Engineer          |(970) 288-2895
GIS Americas         |david_cruise at

-------------- next part --------------
HTML attachment scrubbed and removed

More information about the rsync mailing list