Connection Timeout

tim.conway at tim.conway at
Wed Oct 24 07:55:30 EST 2001

There you go.  "rsync -vn --timeout=0 frank at /local_user/frank/myjsppages", and add the password when it asks, IF it asks.  did you set up the rsyncd.conf with security?  If not, it's "rsync -vn --timeout=0 /local_user/frank/myjsppages".  The ssh stuff will only make it fail, as you're trying to use rsync's internal transport, rather than relying on an external one.
Now, you know, adding -n will mean it will only say what i WOULD do if not running as a dry run (-n== --dry-run), so don't be surprised when nothing transfers.  Also, as the webfiles is a module, it's a directory.  rsync won't just transfer a directory.
see example:
atlas{karrie}% rsync willy::
atlas{karrie}% rsync willy::big .
client: nothing to do: perhaps you need to specify some filenames or the --recursive option?
You'll want to refer to its contents somehow, either just that top level, with /* or simply /, or by a -r (or -r-implying) option.
rsyncd at leasts responds, (the telnet trick).  You're also well on your way to understanding... most people failing to go to a rsyncd aren't even using the correct syntax to refer to the remote resource.

I can finally delete these stupid security disclaimers.

Tim Conway
tim.conway at
Philips Semiconductor - Longmont TC
1880 Industrial Circle, Suite D
Longmont, CO 80501
Available via SameTime Connect within Philips
Available as n9hmg on AIM
perl -e 'print pack(nnnnnnnnnnnn, 19061,29556,8289,28271,29800,25970,8304,25970,27680,26721,25451,25970), ".\n" '
"There are some who call me.... Tim?"

                    "Jeff Sims"                                                                                                               
                    <sims at interex           To:  Tim Conway/LMT/SC/PHILIPS at AMEC                                                               
                    .org>                   cc:                                                                                               
                                            Subject:  Re: Connection Timeout                                                                  
                    03:07 PM                Classification:                                                                                   


The commandline is as shown below:
/opt/rsync/bin/rsync -vn --timeout=0 -e ssh
frank at /local_user/frank/myjsppages

If I telnet to port 873 on the local machine or any machine on my local
network I get the following:
# telnet localhost 873
Connected to
Escape character is '^]'.

If I telnet to port 873 from an outside network it doesn't give feedback,
just says Trying.... and doesn't move.

Here is the feedback from the ssh rsync --version
ssh rsync --version
frank at's password:
rsync version 2.4.6  protocol version 24

Written by Andrew Tridgell and Paul Mackerras

The file /etc/services has this line present:
rsync        873/tcp                 # Rsync server

The file /etc/inetd.conf has the following line:
rsync   stream  tcp     nowait  root    /opt/rsync/bin/rsync rsyncd

I think this covered all of your inquiries and I hope this info is useful.
Thanks for all your help so far.


*********** REPLY SEPARATOR  ***********

On 10/23/01 at 12:35 PM tim.conway at wrote:

>Aaahhh... I see now.  connection timeout, not io or select timeout.
>What's the commandline?
>if it's to a rsyncd, what happens when you "telnet 873"?
>It should look something like:
>tconway at atlas
>/users/tconway>telnet localhost 873
>Connected to localhost.
>Escape character is '^]'.
>@RSYNCD: 25
>If it's not to rsyncd, what happens when you "rsh rsync
>--version" (or if you're doing ssh, ssh instead of rsh, of course)?
>if that fails, is it a permission or network problem?
>Please ignore the following silly confidentiality message.
>The information contained in this message is confidential and may be
>legally privileged. The message is intended solely for the addressee(s).
>If you are not the intended recipient, you are hereby notified that any
>use, dissemination, or reproduction is
>strictly prohibited and may be unlawful. If you are not the intended
>recipient, please contact the sender by return e-mail and destroy all
>copies of the original message.
>Tim Conway
>tim.conway at
>Philips Semiconductor - Longmont TC
>1880 Industrial Circle, Suite D
>Longmont, CO 80501
>Available via SameTime Connect within Philips
>Available as n9hmg on AIM
>perl -e 'print pack(nnnnnnnnnnnn,
>".\n" '
>"There are some who call me.... Tim?"
>                    "Jeff Sims"
>                    <sims at interex           To:  Tim
>                    .org>                   cc:
>                                            Subject:  Re: Connection
>                    10/23/2001
>                    09:48 AM                Classification:
>I just tried the --timeout=0 and --timeout=7200 and I still get the
>following message:
>failed to connect to - Connection timed out
>I am only transferring 3 html files so the transfer shouldn't be that
>I have the timeout in rsyncd.conf set to 0 and used the command option
>--timeout=0 and still it timesout after about a minute and 16 seconds. any
>Ideas or suggestions would be greatly appreciated.
>Jeffrey S. Sims
>Phone: 408.743.4626
>Fax: 408.747.0947
>email: sims at
>*********** REPLY SEPARATOR  ***********
>On 10/23/01 at 8:58 AM tim.conway at wrote:
>>rsync -options --timeout=howevermanysecondsyouwantittobe
>>rsyncdhost::module localpath
>>Note:  I find, usually, that the --timeout is actually, effectively, the
>>total duration of the transfer, as one thread gets nothing after it
>>the other two, until they finish.  It's a bug.  Also, an implicit timeout
>>of 0, specified by not specifying
>>timeout, imposes a select_timeout of 60 seconds.  if you really want 0
>>timeout, you have to do --timeout=0.
>>odd coding.
>>Tim Conway
>>tim.conway at
>>Philips Semiconductor - Longmont TC
>>1880 Industrial Circle, Suite D
>>Longmont, CO 80501
>>Available via SameTime Connect within Philips
>>Available as n9hmg on AIM
>>perl -e 'print pack(nnnnnnnnnnnn,
>>".\n" '
>>"There are some who call me.... Tim?"
>>"Jeff Sims" <sims at> on 10/22/2001 05:25:31 PM
>>Sent by:  rsync-admin at
>>To:     rsync at
>>cc:      (bcc: Tim Conway/LMT/SC/PHILIPS)
>>Subject:  Connection Timeout
>>This is my first post so first of all I will say hello to everyone.
>>I have rsync configured and working properly on my local network however
>>when I try to connect from a remote host (one located in a different
>>state) the connection times out. I was wondering if there was another way
>>to set the timeout besides in the
>>rsyncd.conf file?
>>As I said the connection works fine on the internal lan, but no remote
>>machine can connect. The machine is listed in the host allow variable in
>>the rsyncd.conf file and the username and password are correct. I can ssh
>>from the remote machine in so it
>>isn't a connectivity issue.
>>Any ideas would be appreciated. Thank you
>>Jeff Sims

More information about the rsync mailing list