rsync on cygwin: Connection reset by peer

Dave Dykstra dwd at
Tue Oct 23 01:29:14 EST 2001

Getting back to the original complaint that started this thread:

On Fri, Oct 19, 2001 at 09:04:20PM -0700, Jake Repp wrote:
> I have been trying to get rsync running correctly on cygwin for the past
> couple of days. I found a post on the cygwin list that said there was a
> bug in cygwin when using socketpair() but when I compiled the sample code:
> ( both ways it works fine. Here's the
> article for reference:
> I am running the latest update from cvs
> Here's what happens when I try to get a module list from the cgywin
> system from a freebsd4.4 system:
> fisher          "Fisher Replicated Directory"
> rsync: read error: Connection reset by peer
> rsync error: error in rsync protocol data stream (code 12) at io.c(151)

I do see the same error when listing modules on an rsync --daemon running
under cygwin, connecting to it from Solaris.  I haven't tried to debug it
though, and transfers work OK.

- Dave Dykstra

More information about the rsync mailing list