Rsync Throughput issues

tim.conway at tim.conway at
Wed Oct 10 00:14:31 EST 2001

You might try putting the rsycd (server) on the source.  rsync as a server is really designed for read-only.  The read-write support is an afterthough, and very flaky.  Martin, Tridge, Wayne:  correct me if that's not true any more.
Make sure you're not using --bwlimit=, unless you need to parcel your bandwidth (In my situation, I do).
Don't use -H, unless you actually use multiple hard links to files, as that adds tremendous overhead on large filesystems.
If the files are nfs mounted, use -W, else you will read both files completely, before you transfer anything... might as well just send it if datestamp or size differs.
I doubt ssh was giving you any slowdown, unless you're cpu-limited on one or the other box.  If you don't need the security, and policy permits, plain rsh transport might be a bit faster.

Tim Conway
tim.conway at
Philips Semiconductor - Longmont TC
1880 Industrial Circle, Suite D
Longmont, CO 80501
Available via SameTime Connect within Philips
Available as n9hmg on AIM
perl -e 'print pack(nnnnnnnnnnnn, 19061,29556,8289,28271,29800,25970,8304,25970,27680,26721,25451,25970), ".\n" '
"There are some who call me.... Tim?"

Ben Ricker <rickerb at> on 10/08/2001 06:50:02 PM

Sent by:  rsync-admin at

To:     rsync at
cc:      (bcc: Tim Conway/LMT/SC/PHILIPS)
Subject:  Rsync Throughput issues

I am using Rsync between a Redhat Linux box and an AIX RS600. We have
a about 30gb of database we need to sync to a backup server. Sounds
good, right? The problem is that Rsync is so slow when we do the
initial dump. We have files that are 1 - 5gb. It takes around 14-20
hours to Rsync the file structure, which means our daily backup will
miss that days data because we are waiting for the data to rsync.

At first we were using ssh as the agent but we thought that might be
slowing us down. We then tried to use rsync as a server and push the
data to the module/zone of the server. Consistently, it takes roughly
2 minutes to transfer 10meg of data

I thought it was a network problem so we tried ftp. A 10 mb file took
90% the time (about 20 seconds. This is on a 100bit Full Duplex
switched network with both boxes on the SAME subnet.

Am I missing something? Should I expect these speeds? Could there be
something on the App switch throttling rsync for some reason?

Any thought will help,

Ben Ricker
System Administrator

More information about the rsync mailing list