Rsync Throughput issues

Ben Ricker rickerb at
Tue Oct 9 10:50:02 EST 2001

I am using Rsync between a Redhat Linux box and an AIX RS600. We have 
a about 30gb of database we need to sync to a backup server. Sounds 
good, right? The problem is that Rsync is so slow when we do the 
initial dump. We have files that are 1 - 5gb. It takes around 14-20 
hours to Rsync the file structure, which means our daily backup will 
miss that days data because we are waiting for the data to rsync.

At first we were using ssh as the agent but we thought that might be 
slowing us down. We then tried to use rsync as a server and push the 
data to the module/zone of the server. Consistently, it takes roughly 
2 minutes to transfer 10meg of data

I thought it was a network problem so we tried ftp. A 10 mb file took 
90% the time (about 20 seconds. This is on a 100bit Full Duplex 
switched network with both boxes on the SAME subnet.

Am I missing something? Should I expect these speeds? Could there be 
something on the App switch throttling rsync for some reason?

Any thought will help,

Ben Ricker
System Administrator

More information about the rsync mailing list