Not all files synched - hard link problems???

Dave Madole dmadole at
Wed Nov 28 06:29:54 EST 2001

I am sorry if this has been covered before: I have done a couple of
futile searches in the bug reporting system and is there any way to
search the archive?

I am having a strange symptom:  I am synching directories (that have
very long file names, by the time the full path is specified) and a lot
of hard links.  It seems that the directory is being copied piecemeal -
is, if I run rsync enough times, the entire contents ultimately get
copied.  It seems like I am running into some hard limit in the size of
the filelist or something.

I am running 2.4.6 on linux - the source directory is remote mounted on
solaris, the destination is linux.

For instance, I have a directory that is in the tree that contains 173
files at the source - most of which are hard links - here is the  effect
of an ls | wc on the destination after five succesive identical runs of
rsync on the source (this is in a subdirectory of one of the directories
in the command below).  The directory did not exist before running the

[root at ks-s0-107-1- SC]# ls | wc
     49      49    1286
[root at ks-s0-107-1- SC]# ls | wc
     85      85    2234
[root at ks-s0-107-1- SC]# ls | wc
    120     120    3243
[root at ks-s0-107-1- SC]# ls | wc
    152     152    4112
[root at ks-s0-107-1- SC]# ls | wc
    173     173    4739

So that it seems to have synched 49, then 36, then 35, then 32, the
finally the last 21 files in the directory. (The increment seems to vary
if I try it again, i.e. from 49 to 90).

I get no error mesages (that I can see).  In fact, the first time I run
the program, it seems to notice all
the files and produces 163 messages that "file blah-de-blah" is a hard
link, but then doesn't
seem to make the link for file "blah-de-blah" - this behavior remains
constant with each succesive run.

Here is the rsync command (generated by a perl script and broken into
little pieces by my mailer)

rsync -e 'ssh -l root -p 8989' --rsync-path /usr/bin/rsync --stats
--progress -tpgoCHr -v -v   --include install/ --include
install/kickstart/ --include install/kickstart/zantaz_upgrade/ --include
install/kickstart/zantaz_upgrade/20011121/ --include install/redhat-7.1/
--include install/redhat-7.1/zantaz_rpm_upgrade/ --include
--include install/kickstart/zantaz_upgrade/20011121/** --include
--exclude "*"  /net/swdev/staging/* root at



More information about the rsync mailing list