using rsync to backup windows workstations

Dave Dykstra dwd at
Thu Nov 15 04:28:35 EST 2001

On Wed, Nov 14, 2001 at 10:12:27AM -0700, tim.conway at wrote:
> OK, I might be actually getting this.  Here is part of my sshd_config file
> # To disable tunneled clear text passwords, change to no here!
> PasswordAuthentication yes
> PermitEmptyPasswords no
> this  REQUIRES that a password be used, 

No it does not.  It only makes password authentication one of the options
and when it is used, the password can't be empty.

> # Comment to enable s/key passwords or PAM interactive authentication
> # NB. Neither of these are compiled in by default. Please read the
> # notes in the sshd(8) manpage before enabling this on a PAM system.
> ChallengeResponseAuthentication no
> Do I just need to change the last line to yes
> (ChallengeResponseAuthentication yes) and then when I generate my key on 
> the NT box, put in a passphrase.

No, ChallengeResponse is a totally different kind of authentication method.

> > +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
> > If PasswordAuthentication is yes, then you'll need to ensure that
> > PermitEmptyPasswords is also yes, or you won't be allowed passphraseless
> > authentication.

WRONG.  Passwords have nothing to do with passphrases.

> >         To:     <rsync at>
> >         cc:     (bcc: Tim Conway/LMT/SC/PHILIPS)
> >         Subject:        Re: using rsync to backup windows workstations
> >         Classification:
> >
> >
> >
> > I have about 12 NT servers that I want to backup 1 directory to my Linux
> > Server.  The problem I am having is trying to get it not to ask for the
> > user's password.  I am trying to use ssh.  I just installed the latest
> > cygwin on my NT server (1.3.4).  Rsync is 2.4.6.  What I have tried was 
> on
> > the NT machine, I ran ssh-keygen (no passphrase) and then added the
> > to the Linux box in the /home/thomas/.ssh/authorized_keys.
> > When I run:
> > rsync -uv -e ssh *.* thomas at linuxbox:backup/
> > it asks for a password.  Besides asking for the password, it works fine.
> > Only the files changed are updated and it is FAST! I saw the ssh-agent. 
> Do
> > I need to use it? and how?  Is there something I need to do on my Linux
> > server?  I am pretty new to Linux, and have a long way to go to be an
> > "expert", but I can get around.

The problem is probably that it's defaulting to use ssh protocol 2, and and
ssh-keygen defaults to makeing a key for protocol 1.  If you either run
'ssh -1' or start over with an 'ssh-keygen -t rsa' you should be ok.

Use ssh -v verbose mode to find out for sure what's going on.  You may also
have permissions problems on the server; it requires that all files and
parent directories not be world readable.

- Dave Dykstra

More information about the rsync mailing list