win2k + >2GB files problem

tim.conway at tim.conway at
Fri Nov 9 03:36:42 EST 2001

There's what's probably your problem.  Writing to a daemon is not well 
supported.  Dave, Martin, Wayne, Tridge::: that's still true, isn't it?

Tim Conway
tim.conway at
Philips Semiconductor - Longmont TC
1880 Industrial Circle, Suite D
Longmont, CO 80501
Available via SameTime Connect within Philips, n9hmg on AIM
perl -e 'print pack(nnnnnnnnnnnn, 
".\n" '
"There are some who call me.... Tim?"

Horvath Andras <Horvath.Andras at>
Sent by: rsync-admin at
11/08/2001 08:49 AM

        To:     rsync at
        cc:     (bcc: Tim Conway/LMT/SC/PHILIPS)
        Subject:        Re: win2k + >2GB files problem


Thank you all for the replies. I'm using 2.4 stock of kernels of course,
and I don't use rsh or cygwin on the win2k side, only the compiled
rsync.exe and a cygwin1.dll copied into the rsync directory.

Also, rsync works between any Linux boxes with any size of files, so I
suppose the Linux side must be OK.

I don't use rsh; I tried (mostly) to use the rsync client on the w2k
side w/ rsync --daemon running on the linux.

(I have also tried to start the rsync daemon on the win2k box but had
problems with giving paths and so I gave up doing that.)

rsync'ing locally on the win2k does not work either. ;-(

any more ideas?


More information about the rsync mailing list