rsync doesn't accept commands

tim.conway at tim.conway at
Wed Dec 19 11:38:51 EST 2001

Tim:  I'm ccing the list so they'll know what's going on, save duplicated 
effort, suggest other solutions, etc. ... private mail and all, but public 
forum... anyway, here's the deal i see there.
you're telling rsync to use a password file, used for contacting a rsync 
server.  Then, you use the syntax to use external transport.  you need a 
double colon between the server and the module name.  I assume, of course, 
that you have the server configured and running or started by inetd.

I don't get an error using that wrong syntax - the --password-file  option 
is just ignored, but i'm probably running a different version.
It's possible something funny happenned in options processing.  rsync uses 
something called "popt".  I don't know what that means, but it works for 
does "rsync --version" work?  If not, you're just plain not parsing 
commands.  perhaps you'll see something if you trace the execution. strace 
in linux, i believe.

Tim Conway
tim.conway at
Philips Semiconductor - Longmont TC
1880 Industrial Circle, Suite D
Longmont, CO 80501
Available via SameTime Connect within Philips, n9hmg on AIM
perl -e 'print pack(nnnnnnnnnnnn, 
".\n" '
"There are some who call me.... Tim?"

Tim Shubitz <tshubitz at>
12/18/2001 04:25 PM

        To:     Tim Conway/LMT/SC/PHILIPS at AMEC
        Subject:        Re: rsync doesn't accept commands

   Here's what I was typing in on the "client" end: rsync -ra 
--password-file=/path/to/password.pass /path/to/folder/rsynced 
login at rsyncserver:rsyncmodule and I'd end up with rsync spitting out what 
would appear if you just typed "rsync". I've tried putting in the full 
path of "rsync" (/usr/bin/rsync) to see if that would help in any way. No 
luck so far. I've tried outputting errors to a file but get the same 
thing. No matter what I try rsync only "runs" itself without acknowledging 
commands. This is happening on a LinuxPPC box version 2.2.15. Both ends 
are running the same version (2.3.1). Doesn't really matter since the 
software doesn't get to the point where it could talk to another rsync 
process. Also, it won't work locally, same problem. Thanks for the help. 
Have a wonderful evening.


>which rsync.... make sure you're calling the one you think.  it might be 
>wrapper script or something.
>failing that, can you show me an example?
>Tim Conway
>tim.conway at
>Philips Semiconductor - Longmont TC
>1880 Industrial Circle, Suite D
>Longmont, CO 80501
>Available via SameTime Connect within Philips, n9hmg on AIM
>perl -e 'print pack(nnnnnnnnnnnn,
>".\n" '
>"There are some who call me.... Tim?"

More information about the rsync mailing list