EOF erors

Roger Lipscombe rlipscombe at riohome.com
Wed Aug 15 03:01:58 EST 2001

Randy Kramer wrote:
> Greg Walton wrote:
> >
> > I am new to using rsync so I apologize if this has been answered
> > before.  I still get and unexpected EOF in read_timeout error after I
> > apply all the patches.  Is there another fix that I can try?  Thanks
> >
> > greg
> What are you trying to do?  Are you trying to rsync a large file?

I was having this problem this very morning -- I've just built rsync on
cygwin, however (after patching it so that it passed the host and -l
arguments to rsh the other way round, like cygwin wants them, running it
from the Windows 2000 command prompt resulted in this error.

It wasn't (I think) a big file problem -- it fell over more-or-less
immediately.  Increasing the value of --timeout didn't solve it.

Same problem when I ran it through plink (the ssh thing that comes with
putty).  Except more fun configuring putty, obviously ;-)

Running it through bash on cygwin worked (over rsh).  Go figure.

At first glance, it looks like select() is returning, claiming that there's
some data, but read() is returning zero, claiming that there isn't any.

Other than that, I don't have any ideas.


More information about the rsync mailing list