[clug] What could be stopping dhclient from setting the default route?

Bob Edwards bob at cs.anu.edu.au
Mon Feb 14 06:54:05 UTC 2022

On 14/2/22 11:46 am, Tony Lewis via linux wrote:
> On 14/2/22 11:25 am, Michael Still wrote:
>> Do you have use-routes set to false in 
>> /etc/netplan/...whatever.that.filename.is... ?
> No, it's not mentioned at all.

Ahhh Netplan - the grand solution to a problem that few of us knew
that we had... (and I still don't).

Echoes of UUIDs and Systemd and Network interface renaming... All
sorts of cleverness that is almost impossible to diagnose and debug
until years after their introduction...

Happy that Debian have resisted Netplan, at least in Bullseye...

Bob Edwards (the Linux Luddite)

>> https://aus01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fgithub.com%2Fcanonical%2Fnetplan%2Fblob%2Fmain%2Fdoc%2Fnetplan.md&data=04%7C01%7Cu8909374%40uds.anu.edu.au%7Ce795a152b2cf43aab9b608d9ef537204%7Ce37d725cab5c46249ae5f0533e486437%7C0%7C0%7C637804168022640395%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=FTMSzzNc2rq2rsSaQD7bWYtNbr2xk4pRCj2TON1%2Bi6o%3D&reserved=0 
>> <https://aus01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fgithub.com%2Fcanonical%2Fnetplan%2Fblob%2Fmain%2Fdoc%2Fnetplan.md&data=04%7C01%7Cu8909374%40uds.anu.edu.au%7Ce795a152b2cf43aab9b608d9ef537204%7Ce37d725cab5c46249ae5f0533e486437%7C0%7C0%7C637804168022640395%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=FTMSzzNc2rq2rsSaQD7bWYtNbr2xk4pRCj2TON1%2Bi6o%3D&reserved=0> 
>> for more details. Failing that, I'd run `netplan apply --debug` and 
>> see if that says anything helpful.
> `netplan --debug apply` gave debug info but didn't indicate any 
> problems.  Side note, `netplan apply --debug` gave nothing, and the 
> ubuntu man page's `netplan -debug apply` (single dash) didn't either.
> Tony
>> Michael
>> On Mon, Feb 14, 2022 at 11:11 AM Tony Lewis via linux 
>> <linux at lists.samba.org <mailto:linux at lists.samba.org>> wrote:
>>     I am installing a couple of servers; at the moment, using a very
>>     basic
>>     Ubuntu 20.04 install.  When configuring the network, it selected DHCP
>>     and showed a valid IP, and I leave it at that. However after
>>     booting up,
>>     there is no default route set.  I can't figure out why it's not
>>     being set.
>>     I can add the default route from the command line, and everything
>>     works
>>     until a reboot or until dhclient decides to refresh things. I have
>>     used
>>     wireshark to determine that the default route is being sent from the
>>     DHCP server, both as an option 3 and as a "Next Server IP Address".
>>     I have tried disabling apparmor (there was indications that a
>>     dhclient
>>     script was getting blocked), and I've tried tweaking parameters in my
>>     server's dnsmasq config, but nothing seems to help.  I've also
>>     upgraded
>>     everything to the latest Ubuntu 20.04 packages.
>>     Google shows that some people report problems like this, but they
>>     aren't
>>     exactly the same, and most are old.  Either way they don't solve
>>     things
>>     for me.
>>     Any clues?
>>     Tony
>>     --     linux mailing list
>>     linux at lists.samba.org <mailto:linux at lists.samba.org>
>> https://aus01.safelinks.protection.outlook.com/?url=https%3A%2F%2Flists.samba.org%2Fmailman%2Flistinfo%2Flinux&data=04%7C01%7Cu8909374%40uds.anu.edu.au%7Ce795a152b2cf43aab9b608d9ef537204%7Ce37d725cab5c46249ae5f0533e486437%7C0%7C0%7C637804168022640395%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=OeiqlrOmFagu9BkCKciEPGYXvr88lKChMZwSDH3RYVQ%3D&reserved=0 
>> <https://aus01.safelinks.protection.outlook.com/?url=https%3A%2F%2Flists.samba.org%2Fmailman%2Flistinfo%2Flinux&data=04%7C01%7Cu8909374%40uds.anu.edu.au%7Ce795a152b2cf43aab9b608d9ef537204%7Ce37d725cab5c46249ae5f0533e486437%7C0%7C0%7C637804168022640395%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=OeiqlrOmFagu9BkCKciEPGYXvr88lKChMZwSDH3RYVQ%3D&reserved=0> 

More information about the linux mailing list