[clug] What could be stopping dhclient from setting the default route?

Michael Still mikal at stillhq.com
Mon Feb 14 00:25:02 UTC 2022

Do you have use-routes set to false in
/etc/netplan/...whatever.that.filename.is... ?

https://github.com/canonical/netplan/blob/main/doc/netplan.md for more
details. Failing that, I'd run `netplan apply --debug` and see if that says
anything helpful.


On Mon, Feb 14, 2022 at 11:11 AM Tony Lewis via linux <linux at lists.samba.org>

> I am installing a couple of servers; at the moment, using a very basic
> Ubuntu 20.04 install.  When configuring the network, it selected DHCP
> and showed a valid IP, and I leave it at that. However after booting up,
> there is no default route set.  I can't figure out why it's not being set.
> I can add the default route from the command line, and everything works
> until a reboot or until dhclient decides to refresh things. I have used
> wireshark to determine that the default route is being sent from the
> DHCP server, both as an option 3 and as a "Next Server IP Address".
> I have tried disabling apparmor (there was indications that a dhclient
> script was getting blocked), and I've tried tweaking parameters in my
> server's dnsmasq config, but nothing seems to help.  I've also upgraded
> everything to the latest Ubuntu 20.04 packages.
> Google shows that some people report problems like this, but they aren't
> exactly the same, and most are old.  Either way they don't solve things
> for me.
> Any clues?
> Tony
> --
> linux mailing list
> linux at lists.samba.org
> https://lists.samba.org/mailman/listinfo/linux

More information about the linux mailing list