[clug] Installing CentOS 7 - crash when installing linux-firmware - fixed

Paul Wayper paulway at mabula.net
Sun Mar 24 22:01:00 UTC 2019

Hi all,

Passing this on for those people here that might find themselves in the same

I had to reinstall CentOS 7 on my home server, which runs on an AMD Ryzen 1500
processor.  I initially had lots of trouble with the install, which would
crash when installing the 'linux-firmware' package.  I tried using the same
installer on another motherboard with a AMD Phenom II CPU, but that failed at
the same point.  The installer checksums verified correctly so I did not
expect this to be caused by a failed package.

To get this working, I used the CentOS 7 x86_64 Live DVD image (again, on a
USB key) to boot the machine.  GNOME started correctly and I was then able to
then install CentOS 7 on the system.  This worked on both the AMD Phenom II
and the AMD Ryzen 1500.

My hypothesis is that the installation of the linux-firmware package was doing
a CPU firmware upgrade at the same time, and this caused the package install
to fail.  When CentOS 7 booted from the live DVD, it did the CPU firmware
upgrade.  After that, either the CPU was in the correct state to install the
linux-firmware package or the installation of the package did not also require
the upgrading of the CPU firmware, so the package installed successfully.

Anyway, hope this helps,


More information about the linux mailing list