[clug] Clonezilla - anyone had experience with it?

steve jenkin sjenkin at canb.auug.org.au
Thu Jun 13 12:25:21 UTC 2019

Eyal & Rodney,

Thanks very much for your help and insight. Gives me stuff to look at.

Tried to boot USB on another old machine - BIOS allowed ‘USB Storage’ but didn’t boot from the USB.
I’ll have to look at PXE booting.

Sorry for delay responding - been off-line.


> On 4 Jun 2019, at 20:11, Eyal Lebedinsky via linux <linux at lists.samba.org> wrote:
> On 4/6/19 6:52 pm, steve jenkin via linux wrote:
>> I recently got to use Clonezilla and wondered how others found it.
> I use it often for many years, both for DR backups and full system xfer. Also use it as a rescue boot.
>> It comes as either a Ubuntu or Debian bootable image, running off a USB.
>> Had some problems with booting on an old machine.
>> It worked one day, but when I came back, the UEFI boot failed.
>> An MBR boot version worked fine - but a lot of farnarkling finding a test rig and confirming it would work.
> Never failed to boot, though I mostly boot from PXE, using a USB image when this is not available
> (e.g. imaging the tftp server itself).
> Naturally, booting the iso should the most straight forward method.
>> On The Big Day, cloning an internal SATA disk to an external HDD in a USB-3 dock, it didn’t quite go smoothly.
>> First attempt a week ago had stalled & was killed the next day…  The target 1TB disk was 200k too small as well :(
>> This time round the first copy stalled as well.
> Never had a stall, could there be a disk error?
>> Second attempt got up and running at 9.5GB/min and stayed there, finished 1TB in under an hour.
>> it eventually worked ‘like it said on the tin’. Happy with that.
>> I’m left with many questions:
>> 	- is this “copy stalls on a block, won’t proceed” a common thing? [uses partclone]
>> 	- being a novice with it, I tried device-device copy 1s time and failed because 1TB disks are only same-same.
>> 		- The ext2 source only had 650GB used. Any way to use another option to copy and resize down?
> When the source is larger than the target I resize (shrink) the source to fit, always worked.
>> 	- Stupidly didn’t copy the MBR boot loader (grub I presume) the second time.
>> 		- two reboots and two runs of grub-install & it finally worked.
>> 		- does the MBR copy “Just Work” - I’d had problems with the first stalled & aborted copy.
>> What I’d really like to be able to do is take disk images of a set of 4-5 older Windows systems used for testing.
>> Drives are ~150GB, so a modern ~$100 HDD would fit them all.
> I do this, and also tested the restore which  worked fine. Except...
> 	windows/7 uses a partitioning method that clonezilla cannot restore to (though the backup works).
> 	In this case the disk needs to be partitioned in advance, and the partition images need to be renamed too.
> 	Just don't do W/7.
>> Is this straight forward?
>> Are there gotchas I need to be aware of, especially in rebuilding drives from images?
> If you took a full image then a full restore should work.
> Whatever you decide, verify that an image restore works to a fresh disk.
> -- 
> Eyal at Home (eyal at eyal.emu.id.au)
> -- 
> linux mailing list
> linux at lists.samba.org
> https://lists.samba.org/mailman/listinfo/linux

Steve Jenkin, IT Systems and Design 
0412 786 915 (+61 412 786 915)
PO Box 38, Kippax ACT 2615, AUSTRALIA

mailto:sjenkin at canb.auug.org.au http://members.tip.net.au/~sjenkin

More information about the linux mailing list