[clug] Intel Active Management Technology

Bryan Kilgallin (iiNet) kilgallin at iinet.net.au
Mon May 15 14:45:26 UTC 2017

Thanks, Eyal:

> I have no idea where you got lost, but it is time to stop digging.

I had taken literally what I had perceived to be detailed and precise 

> The build process described in the (earlier provided) github link
> assumes that you understand the need to first fetch the repository.

All assumptions are risks! Whereas I am just an ordinary Ubuntu user.

> Or, if you do not have 'git' installed, click the green "clone or 
> download"
> button (top right), then unzip the delivered file.

I have a tendency to over-concentrate. And so I had read the blue file 
names at the top left:
     * LICENSE;
     * Makefile;
     * README.md; and
     * mei-amt-check.c.
Thereby not noticing that button!

I have now downloaded that bundle to my Downloads directory, and opened 
the files as you recommended.

> Proceed with:
>     cd mei-amt-check

The directory that was created is "mei-amt-check-master". So I changed 
to that directory.

>     make

These were listed.

gcc     mei-amt-check.c   -o mei-amt-check

>     sudo ./mei-amt-check

Interestingly, this was the report. Agreeing with Bob's test result.

"Unable to find a Management Engine interface - run sudo modprobe mei_me 
and retry.
If you receive the same error, this system does not have AMT"

So I entered what the above report suggested, reporting nothing. And as 
recommended, I re-entered the following
sudo ./mei-amt-check

Which resulted in exactly the same error above. Therefore as it advised, 
my system doesn't have AMT.

> This is a standard way of dealing with projects hosted on a git 
> repository.

I'd like to bookmark a Web page for novices, going through such 
rituals--knowledge of which has been wrongly assumed!

> Did you do this and failed?

Your careful explanation worked fine for me.


More information about the linux mailing list