[clug] RTL

Keith Goggin lroyjh at gmail.com
Fri Aug 26 10:32:31 UTC 2016

Has anyone got rtl working on Linux Mint?

I use Linux Mint 17.3 and I installed


and blacklisted

blacklist dvb_usb_rtl28xxu
blacklist rtl2832
blacklist dvb_usb
blacklist dvb_usb_v2
blacklist dvb_core
blacklist r820t

I ran rtl_test OK then the following which seems to work BUT I'm not 
getting any sound?

kg at laptop ~ $ rtl_fm -M wbfm -f 99.1M | play -r 32k -t raw -e s -b 16 -c 
1 -V1 -
Found 1 device(s):
    0:  Realtek, RTL2838UHIDIR, SN: 00000001

Using device 0: Generic RTL2832U OEM

-: (raw)

    Encoding: Signed PCM
    Channels: 1 @ 16-bit
Samplerate: 32000Hz
Replaygain: off
    Duration: unknown

In:0.00% 00:00:00.00 [00:00:00.00] Out:0     [      |      ] Clip:0 
Found Rafael Micro R820T tuner
Oversampling input by: 42x.
Oversampling output by: 1x.
Buffer size: 8.13ms
Tuned to 99352000 Hz.
Sampling at 1008000 Hz.
Output at 24000 Hz.
Exact sample rate is: 1008000.009613 Hz
Tuner gain set to automatic.

I've tried to install shinysdr but I've just dug myself a deeper python 

More information about the linux mailing list