[clug] SANE and scanners

Simon Oxwell soxwell at gmail.com
Mon Mar 23 05:54:39 MDT 2015

On 21 March 2015 at 11:13, Scott Ferguson <scott.ferguson.clug at gmail.com>

> On 20/03/15 12:14, Simon Oxwell wrote:
> > Hi all,
> >
> > Has anyone had a go with SANE and scanners under Linux?
> >
> > I'm running what seems to be the lastest of the SANE backends  (1.0.24).
> > I've got things working, but I seem to have an odd brightness issue,
> where
> > scans are noticeably light on the left and dark on the right. I've made
> > sure I've run the calibration mode and that doesn't seem to have helped.
> >
> > Anyone have any suggestions? My google-fu hasn't turned up anything
> useful.
> >
> >
> > (Scanner is an old CanoScan N650U, which doesn't exhibit the same issue
> > under Windows. Driving the scanner is the last thing I'm using Windows
> for
> > at home)
> >
> >
> >
> > Simon
> >
> Yes. Something in upgrades last month broke my SANE and CUPS
> installations (kept getting "transfer failed" or similar for printer,
> scanner "not found" for scanner).
> Reinstalling the main CUPS and SANE packages fixed the problem.
This one does get weirder and weirder. I've got two old boxes (a PIII and a
PIV, 32-bit, USB2 if they're lucky, much like the scanner), with different
Ubuntus - 12.04 has SANE 1.0.22, and 14.10 has SANE 1.0.24. The box I'm
trying to get the scanner going on is a Haswell-based box with 64-bit
Debian Wheezy that's primarily used as a base for KVM. The scanner scans
without difficulty on the old boxen. No issues, no brightness gradient.

SANE 1.0.22 (default in Wheezy) on the new box has troubles driving the
scanner gantry. I tried a 14.10 Ubuntu (SANE 1.0.24) in KVM and USB
passthrough and it worked, but failed after one scan. I assumed this was
down to KVM/QEMU having USB passthrough issues, so tried Linux Containers
(LXC) instead.

So, a linux container with Wheezy and backport of SANE 1.0.24 package from
Debian Jessie drove the scanner, but has the gradient issue. But the Ubuntu
14.10 version of SANE 1.0.24 on the old PIII works perfectly. Aha, says I,
I'll just recompile the Ubuntu package for Debian. Must have some patches
in it. So did that, and then I get the same scans-once-and-never-again
issue I had with Ubuntu under the KVM.

One of the differences between the Jessie and Ubuntu versions of the SANE
package is Jessie has a patch to reset the USB device after every scan for

So today, I tried disabling USB3/XHCI. SANE 1.0.22 in Wheezy can now drive
the scanner. But I still have the brightness gradient. I guess the next
thing to try is a 32-bit LXC, or 32-bit distro in the KVM. And report to
the sane-devel mailing list.

Slowly, slowly getting there.


More information about the linux mailing list