[clug] Openmoko

Bryan Kilgallin bryan at netspeed.com.au
Fri Oct 31 10:20:39 MDT 2014

Sorry to bother you, Scott:

> I (previous to bricking it) had no issues just using cp, after mounting
> the OpenMoko in USB mass storage mode (Debian).

My working procedure is:
     * in a PC terminal window

	sudo ip address add dev usb0
	sudo ip link set dev usb0 up
	sudo route add -host dev usb0

     * then click on a Nautilus bookmark which does the following.

Is that the kind of thing that you meant? As I am not familiar with the 
terminology of mounting the Openmoko in USB mass storage mode. Whereas 
on reflection, you might have meant to use something like using a mount 
command in a command-line terminal window. Which procedure I'm not 
accustomed to (or got confused about the last time I tried!).

But as the phone has the cp command, I thought of using that to transfer 
a file from there to the PC. Just to explore more how to do stuff. 
However I ran into the problem that I didn't know how to tell cp the 
remote (IP or host name) address. So that I couldn't figure out how from 
a terminal window doing SSH into the phone, to specify to copy a file to 
my home directory on the PC.

> Otherwise, zcat (in /bin), and take a look in /usr/bin for other
> transfer utilities.

I am not familiar with using zcat, though I found it in the phone's bin 
directory. I also noted as you suggested that there were many programs 
listed in the phone's user binaries directory. But I will need to 
examine that user binaries directory listing with the help of a PC 
terminal window, so as to work out what each program did!

Thanks again for your trouble.


More information about the linux mailing list