[clug] Debian Jessie (Testing, ) "no installable kernel was found in the defined APT sources"

George at Clug Clug at goproject.info
Fri Oct 17 20:23:51 MDT 2014

    Thanks Bob.

This morning I downloaded the net-inst iso
"debian-jessie-DI-b2-amd64-netinst.iso" and this iso allows me to
build Jessie VMs under VMware Workstation and under KVM.  The iso
that I have previously downloaded is
"debian-testing-amd64-netinst.iso" which is the iso that could not
find a kernel.

Do you use KVM for any of your Jessie installations?  I am using
"qxl"  and Spice for a Cinnamon KVM installation and it reports
"Running in software rendering mode".  This is not displayed in
VMware Workstation's VM.

I would like to trial Jessie with Cinnamon on a real hardware. I have
liked Cinnamon now for a while but since I usually run Debian stable,
I have not done run it as my GUI. I do like Cinnamon in Jessie.
Previously when I used Linux Mint I had issues where copying large
files failed. Today all worked well.

To install Debian testing, we recommend you use the Jessie Beta 2
release of the installer, after checking its errata [1]. The following
images are available for Jessie Beta 2: 
netinst (generally 150-280 MB) CD images


At Saturday, 18-10-2014 on 12:18 Bob Edwards wrote:

On 17/10/14 10:53 PM, Tomasz Ciolek wrote:
> I have been running jessie/testing for a while now...
> To get to jessie, ideally you install wheezy, then change your
osurces.list, and then do
> apt-get update && apt-get dist-upgarde
> Tomasz

+1 (ie. that's also what I do).

I have about 4 boxen running Jessie. ("about" because two of them are
virtual and not always running).

To "change your osurces.list", I do:
# vi /etc/apt/sources.list

(then the apt-get update etc.)

Bob Edwards.

> On Fri, Oct 17, 2014 at 10:03:33PM +1100, Simon Oxwell wrote:
>> Hi George,
>> Jessie is still a bit alpha, isn't it? Having trouble finding an
>> for it myself, but assuming you were doing a network install, the
>> you picked might not be mirroring anything past wheezy.
>> Simon
>> On 17 October 2014 21:53, George at Clug  wrote:
>>>      Hi,
>>> I recently tried to install Debian Jess using VMware Workstation
>>> and the installation fails with the error "no installable kernel
>>> found in the defined APT sources". Has anyone else seen this issue
>>> I finally succeeded using the following suggestion from a web
>>> The solution I found was to let the installation continue (say Yes
>>> the message asking if you want to continue without installing a
>>> kernel).
>>>   Then, when the final prompt "Installation complete" appears
>>> the one that appears just before it goes down for reboot), do the
>>> following:
>>> 1.Press Alt+F3 to switch to a virtual console, then press Enter to
>>> activate it.
>>> 2.Type "apt-install linux-image-amd64"
>>> 3.Wait for the prompt to re-appear (you can monitor progress by
>>> pressing Alt+F4, but you must Alt+F3 to see whether it's actually
>>> finished)
>>> 4.When the installation of the kernel is complete, press Alt+F1 to
>>> return to the installer, and press Enter with the Continue button
>>> highlighted to reboot the system
>>> (http://ubuntuforums.org/showthread.php?t=1550587)
>>> --
>>> linux mailing list
>>> linux at lists.samba.org
>>> https://lists.samba.org/mailman/listinfo/linux
>> --
>> linux mailing list
>> linux at lists.samba.org
>> https://lists.samba.org/mailman/listinfo/linux

linux mailing list
linux at lists.samba.org

[1] https://www.debian.org/devel/debian-installer/errata

More information about the linux mailing list