[clug] rsync question [solved]

Eyal Lebedinsky eyal at eyal.emu.id.au
Sat Jun 22 19:02:04 MDT 2013

I ran a small test on one failed directory and this time I *did* see permission errors.
I ten realized that I need to tell rsync daemon to launch as root and added
	uid = root
	gid = root
to the config.

Things look much better now...

I am still unsure as to why this happens. I somehow expected that running the command
as root will launch the daemon as root (on the other side) too, with proper authentication.
I probably need to read the doco more closely.

Thanks everyone,

On 06/22/13 20:03, Eyal Lebedinsky wrote:
> I am moving data between two arrays. I use this command
>      rsync -aSv --progress rsync://root@e7/root/data1/ /data1
> to pull the data from 'e7' to a local disk (both arrays mounted on /data1 and
> 'root' is a module that exports e7:/, created just for this purpose).
> Not all the data seems to arrive. The copy did not complete but one of the large
> subdirectories shows less files in the target (71k) than the source (82k).
> Does rsync copy full directories in order or can some files arrive later?
> Sourcing as 'root at e7' should give me read access to everything - right?
> Also, am I correct that rsync does *not* encrypt the data, and since the
> two arrays can do ~500MB/s I should expect the wire to be the limiting
> factor? The only CPU work is the checksum calcs.
> /etc/rsyncd.conf
> ================
> [root]
>      path = /
>      comment = everything

Eyal Lebedinsky	(eyal at eyal.emu.id.au)

More information about the linux mailing list