[clug] Display problems following upgrade...

Ben Davies bdcrux at gmail.com
Sun Dec 8 04:36:19 MST 2013

On 5 December 2013 14:31, Andrew Janke <a.janke at gmail.com> wrote:
> Given you said 5 years ago, I'm guessing an old school xorg config
> when you got to fiddle with things by hand/vi and felt good about it.

I think the last version I installed from scratch was probably Lubu
13.04. This laptop didn't like the Ubu 10.04 to 10.10 u/g either, and
the GUI went to crud right after (fixed with a complete reinstall...).

> <snip>  So you have two options.
> 1. Scorched earth: re-install from scratch!   (not a bad idea, I set
> my drive on the laptop up with 3 partitions, one for current OS, one
> for the next OS, one for home directories. I use a swapfile not a swap
> partition. From there I have a dodgy shell script which copies back
> the small amount of config that I do.
> 2. Scorched continent.
> Try to remove everything and anything to do with nvidia.
>    apt-get remove --purge *nvidia* *glx*
>    rm ~/.nvidia-config*
>    replace xorg.conf with the default. (rm, apt-get install
> --reinstall xorg....)
> reboot (ensure it is in fallback mode)
> then re-install nvidia using the control panel and friends. You will
> still have to install nvidia-settings as I am yet to see a inbuilt
> displays control panel that can handle all the nvidia config options.
> Works for simple stuff via the open source neuveau(sp?!?) driver but
> not for the binary blob nvidia driver.
> As a PS: one more trick to try is to login as a new/clean user, nvidia
> stores config in your home directory that can cause amusing things to
> happen.

I tried the scorched continent method with little gain. Getting rid of
the nvidia packages (no glx pkgs were installed) brought the
resolution back to something more acceptable. There was still the
problem with the login failing and dumping back at the password

Installing a fresh 13.10 (sans nvidia pkgs) over the top of the old &
using the original home settings didn't solve anything either. A quick
adduser & trying that login went to the default desktop with no

I noticed ~/.Xauthority had root:root ownership. Not sure when/where
that happened, but reverting it fixed the login problem. Reinstalling
nvidia-current and nvidia-settings & rebooting seems to have solved
the gfx problems following the last update. The laptop happily started
up from hibernation earlier.

Thanks for the help - this is a great list :-)


More information about the linux mailing list