[clug] linux Digest, Vol 105, Issue 6

Rodney Peters rodneyp at pcug.org.au
Mon Sep 5 16:56:49 MDT 2011

On Tue 6 September 2011 04:00:06 linux-request at lists.samba.org wrote:
> I have a Gigabyte AM3 motherboard (specifically a GA-MA785GM-US2H) which 
> takes DDR2 800Mhz memory. I have a dual core AM2 CPU in the machine if 
> that matters.
> The machine worked fine with 2 * 1GB DDR2 memory. I just tried to 
> upgrade to 4 * 2GB DDR2 memory, which the motherboard manual says should 
> be supported. However, in this configuration the machine doesn't boot. 
> It doesn't even get to the BIOS, it just reads from the empty DVD drive 
> over and over. The machine does boot with just 2 * 2GB though.
> Any hints?
> Thanks,
> Mikal

Firstly I suggest you go to the Corsair site (regardless of what brand of RAM 
you have) and download their:

AN806 Memory Upgrade Resource Guide

In particular, they point out that having 4 DIMM slots is no guarantee that a 
particular motherboard will ever handle 4 DIMMs.

I had an entry level ECS AM2 mainboard which had only 2 DIMM slots - it would 
not boot with 2 x DDR 800.  I reduced it to one DIMM - that got it booted, 
then hard-configured the frequencies, voltages etc specified on the DIMM 
modules, powered off and installed the second DIMM.  Then worked OK.

I suggest that you try the same approach, with 2 DIMM installed initially.  
Explanation - the BIOS tries to autoconfigure RAM parameters and apparently 
fails with some modules.  If your pairs of DIMM require different voltages, 
timings etc then the mainboard may not differentiate those between the DIMM 

My current mainboard is an AM2+ J&W running an AM3 dual-core Athlon.  It does 
handle 4 x DIMM without any hassles - so it is possible.  But they happen to 
be DDR 1066, although it runs them at DDR 800 - see below.  

BTW, dual-core, ie Athlon, AM2 don't go beyond DDR 800 speed - the memory 
controller is in the CPU.

If all else fails then your best course of action might be a pair of 4GB DIMM 
and DDR 1066 might have better chance of sucess - but check that those require 
the standard 1.8V voltage setting.


More information about the linux mailing list