[clug] Dist-upgrade woes - was Re: Advice request on upgrade to Debian Squeeze local mirrors?

Scott Ferguson scott.ferguson.clug at gmail.com
Thu Mar 24 16:41:00 MDT 2011

On Wed, 23 Mar 2011 18:44:37 +0000 (UTC) Felix Karpfen wrote:
> On Wed, 23 Mar 2011 10:13:37 +1100, Scott Ferguson wrote:

> We were both wrong; but you were closer.

Don't matter how much you miss a target by, a bad shot is a bad shot ;-p
(I was just wrong)

<snipped in case length is why the dog ate half my last post>

> When the dist-upgrade started, my CD drive was called /dev/hdc. The
> entry in my /etc/fstab reads:
> /dev/hdc        /media/cdrom0   auto    ro,user,noauto  0       0
> There is a sym-link from /media/cdrom0 to /cdrom;
> and the "apt-get" routines only recognise "/cdrom".
> When I was asked (by apt-get dist-upgrade) to insert my first DVD into the
> disk drive, /cdrom worked - because it pointed to /dev/hdc.
> By the time the dist-upgrades on the first DVD were completed, the drive 
> was renamed (according to the "mount" command) /dev/sr0. And /dev/sr0 
> does not have a mount point.
> Going to a separate terminal and trying "umount" routines did not work;
> the message was that the device is busy.

umount -dl /dev/cdrom
add -f if it still complains

My relevant /dev entries after a dist-upgrade:-

lrwxrwxrwx   1 root root           3 Mar 25 09:03 cdrom -> sr0
lrwxrwxrwx   1 root root           3 Mar 25 09:03 scd0 -> sr0
crw-rw----   1 root cdrom    21,   0 Mar 25 09:03 sg0
brw-rw----+  1 root cdrom    11,   0 Mar 25 09:03 sr0
lrwxrwxrwx   1 root root           3 Mar 25 09:03 dvd -> sr0

So it shouldn't matter.... else try adding a sym link as suggested by
David. There's also a remount option, but I've not tried it under these

> At least I was able to do a clean shutdown this time.
> When I restarted Squeeze, I can get into a terminal and manually mount
> /dev/sr0 (with the second Squeeze DVD inserted).  When I then try "apt-
> get dist-upgrade" it found the disk but crashes because of unmet 
> dependencies.  It suggest running the command with the "-f" flag.

I'd suggest checking the outcome for sanity first:-
#apt-get -sf install | more (or less).
Note: not dist-upgrade, just ask apt to show us what it has not completed.
If it looks sane:-
#apt-get -f install

> I cannot do a normal boot; the message reads:
> There already appears to be an X server running on display :0.

I wouldn't boot into multi-user mode until the upgrade is completed,
especially if you were previously running non-free drivers (eg nvidia).

> So all is not lost.  
> But I thought it prudent to post this message and request comments before 
> I do any more experimenting.  
> Felix

Sorry I don't have a simple solution - I'm still going to wait until the
end of Lenny's Security updates before moving my main work machines to


More information about the linux mailing list