[clug] Kubunbtu 10.4

Keith Sayers keiths at apex.net.au
Sun Jun 19 15:59:04 MDT 2011

On Saturday 18 June 2011 an ever helpful Owen Cook responded :

> If you have problems, simply copy the /etc/fstab and post here where a
> few more eyes will look at it

# /etc/fstab: static file system information.
# Use 'blkid -o value -s UUID' to print the universally unique identifier
# for a device; this may be used with UUID= as a more robust way to name
# devices that works even if disks are added and removed. See fstab(5).
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
/dev/sda1       /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda5 during installation
UUID=8dd25579-49cd-4446-aa1a-c64441079fc6 none            swap    sw              0       
/dev/fd0        /media/floppy0  auto    rw,user,noauto,exec,utf8 0       0

	So it seems to not offer me the UUID previously quoted.  And I tried that blkid bit 
but it did nothing.

	However this from Scot Ferguson sent me on another line :

> The only other problem you might have is if, in swapping hard drives,
> you've now got two drives with bootable partitions. It won't cause the
> problem you've posted (grub bitching it can't find the partition
> described by uuid) - but it can cause problems.

	I used Partition Manager from a parallel hard drive ('Trevor' - for clarity I have 
named all my hard drives.  I have accumulated several and consolidating them is the 
current objective.) to view the recently loaded hard drive and found that I had two major 
partitions - one (sda1) empty but carrying the boot flag and another with (presumably) the 
Kubuntu loaded (sda2).  I cancelled that boot flag, moved it to sda2, deleted the sda1 
partition and rebooted.  Still the same screenful of messages.

	So back to Partition Manager whence found that I now have a large unallocated block, 
then an extended partition sda2 flagged as boot and divided into three - most of it into 
sda6 with an ext4 filesystem and then two small linux swap partitions - sda7 and sda5. (Do 
I really need two linux swap partitions?)  I have obviously messed up somewhere and now 
remember that I had a small problem during the load which I resolved by opting for 'the 
largest contiguous unoccupied block' or something similar.  I think the most sensible move 
would be a complete reload.  I will wipe all the extant partitions, replace with just one 
contiguous partition, reload and see what happens.  But for the sake of knowing should 
there be some way of taking that unallocated block and merging it into the extant sda6?  
It does not greatly matter because there is ample room on the drive for all I want to do 
but it might be a useful lesson learned.

Keith Sayers                                                       keiths at apex.net.au
6 Clambe Place
Australia                                            http://www/apex.net.au/~keiths

More information about the linux mailing list