[clug] Rescue cd in Cairns

Brett Worth brett at worth.id.au
Tue Jul 26 06:48:01 MDT 2011

Fellow travelers,

I'm happy to report that I am now back on-line.  Given that  I'm really just lazing around 
I'll give a recap as to what happened.  Please delete now if if you're not interested 
since this is a bit off topic.

It all started last night.  I'd been tethering to a mobile broadband account via my phone 
and suspended the machine.  Later, when I tried to unsuspend it, there was just nothing on 
the screen.  Normally when coming out of suspend there is no Dell BIOS splash screen, just 
a prompt for a password after a second or two but this time it was dead.  You could see 
the back-light come on but no display. A control alt delete would make the screen go dark 
and back to black with back-light.  I could get nowhere and suspected that the system was 
in a mode where it thought it was supposed to be unsuspending but corrupt.

My next try was to run the battery flat so that it would be powering up with no suspend 
state in ram.  This took a while but once it was flat it would still give no display on 
power-on.  This was never really totally flat because it just turns itself off when the 
battery is very low.

This brought us to this morning when I thought it worth a try to get it to boot from a 
Linux CD to see if loading a fresh kernel might clear it.  It was still not clear at this 
time whether the Kubuntu I was running might have put it into this weird state.

After my call for help this morning to the clug list I got a great response.  If I'd 
followed up all the offers I think I'd have about 4 bootable Linux CDs by now.  Thanks to 
all.  I collected a rescue CD from a local sysadmin and when I got back tried to boot from 
it but the problem persisted.  In fact it started exhibiting a new problem in that the 
screen started displaying garbage occasionally.

I finally gave up and rang Dell.  The Dell tech support person was very easy to deal with. 
  After describing the symptoms he said we should try running some diagnostics.  I was a 
bit worried that he  was going to want the existence of the Dell Utility partition which 
had actually suffered the same fate as Windows.  He asked me to hold down the "Fn" key 
while powering it on which as it turns out invokes a detailed built-in diagnostic suite. 
When I ran this (blindly) the symptoms didn't  change but, after a few minutes and while I 
was discussing the details of getting someone out with some parts, the screen started 
displaying solid colours in a sequence.  Once this was complete it went back to the 
original symptom.  I was still on the phone and giving my address details when I thought 
I'd power it off and back on.  It was totally fixed.

So what happened. My guess is that perhaps this might not have happened if it was running 
Windows.  That said I think the BIOS has some bug in it where it's failing to initialise 
something that it should be initialising.  Running the diagnostics did the job for it. 
This computer (Dell 15z) cannot have it's battery removed without using tools. Perhaps I 
should have brought some jewelers screwdrivers on holidays.  A good ol' battery 
removal/reinstall probably would have fixed it too.

So now I have a work-around and have learned how to run the builtin diags.  I'll also 
eagerly await BIOS updates.  Do I actually have a hardware problem?  I hope not.

Once again thanks to all who were able to offer assistance.  After all, what sort of a 
holiday would it be if I couldn't do what I already do  for a living?  Wait...


   /) _ _ _/_/ / / /  _ _//
  /_)/</= / / (_(_/()/< ///

More information about the linux mailing list