[clug] Booting problem

steve jenkin sjenkin at canb.auug.org.au
Tue Oct 20 01:51:25 MDT 2009

Rod Peters wrote on 18/10/09 8:47 AM:

> The fact that Keith has put the HDD in a different computer (read different 
> mainboard) leads me to believe it is probably an initrd issue.  openSUSE puts 
> the required PATA and/or SATA modules only in the initrd.  Options are:
> put it back with the original mobo and use Yast to *add* the relevant modules 
> (which does not appear to be an option in this instance)  Had to do this 
> myself recently.
> find another mainboard having same PATA controller
> boot from CD/DVD and select "repair installed system".  That will do a fairly 
> thorough review of the config files and should rebuild initrd.


> Rod

I trotted around to Keiths' this afternoon and had a look, but knowing
little of openSUSE hit a road-block.

The problem is indeed with 'initrd' lacking the right disk drivers.

The old Mobo is defunct - not an option going back.
I turned off SATA in the BIOS on the new HDD, but that didn't help.

I ran SUSE 11.1 'repair installation' - which got most of the way
through, recognised the initrd problem & named the missing modules -
then promptly failed with:

  'mkinitrd not found'

There is a spare partition on the drive and I tried to do a fresh
install from the 11.1 CD we had (CD 1 or the LiveCD - not sure).

This also failed. It couldn't create a repository file from the CD.
[Saw the same error with 'repair']

I tried booting SuSE 10.0 and selecting 'rescue' - which allowed me to
examine the partition table & verify there was spare space - but didn't
know the commands to run...
(Which could have been as simple as 'mk_initrd' or 'mkinitrd' now I've
had some access to the Net)

My current plan is download a fresh SuSE 11.1 disk and go visit Keith
again tomorrow afternoon.

Anyone have any pointers or further suggestions for me?
[esp. URL's talking about repair/rescue. I didn't try the 'customise' or
'expert' options.]


Steve Jenkin, Info Tech, Systems and Design Specialist.
0412 786 915 (+61 412 786 915)
PO Box 48, Kippax ACT 2615, AUSTRALIA

sjenkin at canb.auug.org.au http://members.tip.net.au/~sjenkin

More information about the linux mailing list