[clug] Getting a Slmodem to work on M912x tablet PC

Denise Bates dbates at fwi.net.au
Tue Jan 13 03:03:36 GMT 2009

Hello folks,

I am having great difficulty in getting an external Netcomm Rave11 USB 
modem to work on a friend's Gigabyte M912x tablet PC. I seem to have 
licked all the other problems with the Slackware12.2 installation, but 
the modem has me stumped.

The modem works "out of the box" with Puppy Linux 4.1.2 on this machine 
as /dev/ttySL0: No other distro that I tried does this, even with 
extensive fiddling. It seems to need /dev/slusb and it doesn't appear in 
any other distro that I have tried and none of the three types of driver 
installations seems to create /dev/slusb.

Driver installation method #1.  I downloaded several versions of RPMs 
from http://linmodems.technion.ac.il/packages/smartlink/ and "installed" 
them, both as RPMs and by converting them using rpm2tgz to do a "proper" 
Slackware install. No /dev/slusb appears. Modem is not recognised on 
reboot. Typing "slmodemd" produces a message that /dev/slamr can't be 
found (this appears to be for internal winmodems, not USB).

Driver installation method #2. I downloaded drivers, resembling "source" 
files and tried to install them (make clean, make, make install). Modem 
still not recognised: result as above. I searched through the makefiles 
and replaced every occurance of "slamr" with "slusb". Same result.

Driver installation method #3.  I manually copied "slmodemd" into 
/usr/local/sbin and added a few lines to /etc/rc.d/rc.local
/usr/local/sbin/slmodemd -c AUSTRALIA --/dev/slusb
ln -s /dev/ttySL0 /dev/modem
chgrp users /dev/modem

Still no luck!

I suspect that the solution is quite straightforward, as the modem works 
so well in Puppy, but I just can't see it.
Any suggestions would be appreciated.


Denise Bates <dbates at fwi.net.au>
PO Box 516
Goulburn NSW 2580

More information about the linux mailing list