[clug] xorg config

Mike Carden mike.carden at gmail.com
Fri Aug 28 22:18:44 MDT 2009

Thanks Dave.

I dropped a "Module" section into xorg.conf with glx and others in it.
I also tried adding the intel driver to the "Device" section but no
joy. Just in case I tried i810 instead of intel but still no joy. My
xorg log file contains these clues:

mc at alloy:~$ less /var/log/Xorg.0.log | grep -i glx
(II) "glx" will be loaded. This was enabled by default and also
specified in the config file.
(II) LoadModule: "glx"
(II) Loading /usr/lib/xorg/modules/extensions//libglx.so
(II) Module glx: vendor="NVIDIA Corporation"
(II) NVIDIA GLX Module  96.43.05  Tue Jan 22 20:11:30 PST 2008
(II) Loading extension GLX
(EE) intel(0): [dri] I830CheckDRIAvailable failed: glx not loaded
(EE) Failed to initialize GLX extension (Compatible NVIDIA X driver not found)

All of which has me wondering why my friends at NVIDIA corporation
need to get in on the act with my intel video subsystem.

I guess I could cross my fingers, upgrade the system and hope for the best, but:

(a) I won't have learned what's going on and,
(b) I have an awful track record of failed system upgrades.



More information about the linux mailing list