[clug] Linux on Palm

Fred Pilcher fpilcher at netspeed.com.au
Sun Sep 21 06:29:44 GMT 2008

Alex Osborne wrote:
> Hey Fred,
> On 15/09/2008, at 12:34 PM, Pilcher, Fred wrote:
>> There are lots of references on the web about installing Linux on the
>> T3, but they're generally either a couple of years old, in Spanish,
>> and/or far beyond my technical expertise.
> http://hackndev.com/ is the main site for the palm ports.  Although most 
> of the developers don't speak english as a first language and just work 
> on this out of personal interest so haven't written much in the way of 
> easy to understand user documentation.
>> Has anyone actually done it and, if so, would they be willing to give me
>> a hand?
> I haven't worked much with the T3 specifically, but you should be able 
> to get some binaries from kEdAR's website:
> http://kedar.palmlinux.cz/
> Create directories /palm/launcher and /linux2ram on a FAT-formatted SD 
> or MMC card, if they don't already exist.
> The style of kEdAR's page is a little creative but the pieces you should 
> need, and where to put them on the memory card are:
> 1. Kernel: /
> http://kedar.palmlinux.cz/zImage.k106
> 2. Bootloader: /palm/launcher
> http://kedar.palmlinux.cz/palm/launcher/cocoboot-0.4.prc
> 3. Bootloader config: /
> http://kedar.palmlinux.cz/cocoboot.conf
> 4. Initrd: /
> http://kedar.palmlinux.cz/initrd.k106.gz
> 5. Kernel modules: /linux2ram
> http://kedar.palmlinux.cz/linux2ram/modules-k106.squashfs
> 6. Root filesystem: /linux2ram
> http://kedar.palmlinux.cz/linux2ram/rootfs-OpieMini20070719-xscale.squashfs
> 7. Device nodes: /linux2ram
> http://kedar.palmlinux.cz/linux2ram/dev_tt3.squashfs
> 8. kEdAR's patches to the filesystem for T3: /linux2ram
> http://kedar.palmlinux.cz/linux2ram/kedar_changes.squashfs
> Chuck in the card and you should find a new program "Cocoboot" with tux 
> icon in the PalmOS launcher (you might need to select the card's 
> category from the drop down menu).  Run it and hit boot and see if it 
> works.
> If it doesn't work, let me know.  I have an old partly broken T3 lying 
> around somewhere which I can dig up and give it a go on.  Given I 
> originally wrote Cocoboot, I guess I should have a decent chance of 
> debugging it. ;-)
> Cheers,
> Alex

:-) Tried it, but when I hit Boot I get:

829 Palm Tungsten T3
Loading/zimage.k105... failed. (-1/-3)

I notice that, when I put the card in an start Cocoboot, it says:

/zimage.k105 not found(-3)
/initrd.k105.gz not found!(-3)

Could that be just a matter of editing cocoboot.conf and replacing k105 
with k106?

Thanks again, Alex!


More information about the linux mailing list