[clug] 32/64 bit compile

Brian bnc at astronomicalresearchaustralia.org
Sun Feb 17 00:08:31 GMT 2008

Yes I have tried all the suggestions put forward.
Learnt heaps in the process:)
Yes I do have the developer tarball and after looking around a fair bit
I am convinced the problem lies with the way the apogee code calls the
modpost code.

I finally found the code which in part says
 := ld -m elf_i386 -r -o /opt/apogee/src/apogee/module26/apogeePPI.ko
so I am pretty sure that this is what needs to be changed.

Thanks for all your tips certainly put me on the right track.

In any event the developer got back to me this morning and asked me to
try a few things.
So I will post back when I get a result.


steve jenkin wrote:
> Jim Watson wrote on 16/2/08 3:43 PM:
>> Brian wrote:
>>> Hi all,
>>> I am compiling a prog on a 64bit AMD, currently runs on a 32bit machine.
>>> <snip>
>>> Is that my best option, if so how do I change the above make to force a
>>> compile in 32bit?
>> Maybe try working in a 32 bit shell?
>> before you start anything:
>> $ linux32 bash
> I've had an short off-line email conversation with Brian and he's seems
> stumped still.
> Not sure if he's tried the solution in this mail.
> Is there anyone out there who knows how to do 32-bit & 64-bit compiles
> and can take a little time to either visit or talk Brian through this??
> I believe he has full source code, but not completely sure...
> The developer at 'randomfactory' has gone quiet lately, so his normal
> support isn't available.
> What's certain is that libccd.so is built 32-bit and the build process
> doesn't cater for 32/64-bit versions.

More information about the linux mailing list