[clug] Local NTP server?

Chris Smart mail at christophersmart.com
Tue Dec 23 05:53:44 GMT 2008

2008/12/23 Andrew Janke <a.janke at gmail.com>

>   Again, to harp on... if you use openntpd just add the -s option
  to /etc/default/openntpd :)

OK, I tried openntpd on the server:

sudo apt-get remove --purge ntp  && sudo apt-get install openntpd

Then I edited /etc/default/openntpd and uncommented the '-s' option, told it
to listen on all interfaces and restarted the deamon.
netstat shows that ntpd is listening and ps shows that it's running (two
instances, one as root, one as ntpd). As an aside, when I add the -s it does
take an awefully long time to start, but without -s it's almost

OK, onto the client now:

sudo apt-get remove --purge ntp
sudo ntpdate
No joy

does not error, but nothing changes. I tried with and without -s.

Next, install openntpd on the client, hoping I can sync to the other openntp
sudo apt-get install openntpd

I edited the -s option and restarted. Still nothing. Log showed the deamons
starting and stopping, but nothing else.

Maybe there's something more funky going on here. I noticed in tcpdump that
some upd packets were corrupt. Perhaps that is breaking things? (Although I
think the problem is most likely me.)

I'm gonna try at home and see if it (or just anything) works there.


More information about the linux mailing list