[clug] Re: xming/slackware/win xp question (linux Digest, Vol 64, Issue 21, Topic 7)

Miles Goodhew miles at m0les.com
Wed Apr 30 00:16:02 GMT 2008


> Message: 7
> Date: Tue, 29 Apr 2008 06:35:21 -0400
> From: David Saunders <drs8h at iinet.net.au>
> Message-ID: <4816F9E9.40306 at iinet.net.au>
>   I have been trying to run X client output from my slackware 12.0  
> linux
> box to display on my win xp sp2 box without success.

	I do this all the time (albeit Win2k) at work.

>   I have an adsl 2+ Belkin router provided by IINet and both machines
> are in my home office.

	... Which I think is irrelevant, but thanks for being thorough.

>   I am using Xming + it's font package and have alternated between  
> putty
> and secureCRT in trying to get x11-forwarding going.  The instructions
> are pretty trivial--start Xming, start an ssh -X (or -Y)  session from
> the win xp system to the linux system, set DISPLAY (although some
> instructions sometime indicate that this is unnecessary for an ssh
> tunnel), and start the x client from within the ssh session on the  
> linux
> box (it should display back to the win xp box).

	I use CygWin's X11 which works just fine for me. I tunnel through  
either PuTTY or CygWin SSH - both work fine.

>   I have turned off the win xp firewall, checked the router for any
> possible problems from it, and have tried lots of permutations, all
> without success.  I have also run Xming without the -clipboard option,
> because of comments I found on Google indicating that this causes
> problems of some sort.

	I _think_ that the firewall shouldn't be a problem. The ssh tunnel  
should be connected locally to either the localhost interface or any  
named-pipe or unix-domain socket interface (If there is such a  
concept under Win32).

>   I have tried to be patient and allow the X dialog to complete
> (although the machines are not excessively old), but no reward has  
> been
> forthcoming.
>   Finally, I sometimes observe that Xming will occasionally have 1
> client connected, but nothing displayed.
>   Any ideas would be appreciated.  Thanks,

	I suspect the problem (Prob. Xauth) is on the remote site (X client  
side, FWIW), but here's a little checklist:

	1) Make sure X11 server works locally (run xeyes or xdpyinfo on your  
Win32 box - if there is such a thing for XMing)
	2) Make sure the remote site can run X applications on its own local  
display. If you're trying to have this completely headless, then you  
need to install enough of the X11 infrastructure to have the xauth  
utility installed (sorry, you'll have to google what exactly you need).
	3) Make-sure X11 forwarding is permitted on the remote site's sshd  
config (I believe it usually IS though).

	When you use an SSH-tunneled X11 session, the SSH server sets-up a  
supplimentary X11 display on the remote (X11 client) side of the  
connection. These supplimentary displays tend to start numbering from  
10-up (i.e. "DISPLAY=localhost:10.0" or ":10.0" for short). Depending  
on how your remote (X11 client-side) X is set-up, this might boil- 
down to a named-pipe/socket in "/tmp/.X11-unix" or somesuch.  
Essentially, what I'm saying is SSH-ing in and manually doing "export  
DISPLAY=:0.0" is never going to work due to ":0.0" meaning "Remote- 
end's local display". If the SSH server doesn't set the DISPLAY  
variable for you, your tunnel's not in place - don't bother trying to  
"force" it.
	If that's the case, snuffle through your log files to see what the  
server is complaining about (I bet it can't find xauth).  
Alternatively see if the SSH client can ramp-up its logging verbosity  
(The OpenSSH client has several levels of verbosity).

Good luck,


Miles Goodhew
miles at m0les.com

More information about the linux mailing list